Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80621 - Conf.py:473:__delitem__: KeyError
Summary: Conf.py:473:__delitem__: KeyError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 97825 (view as bug list)
Depends On:
Blocks: 79578 81720
TreeView+ depends on / blocked
 
Reported: 2002-12-28 22:03 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-28 21:53:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Ted Kaczmarek 2002-12-28 22:03:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
Neat crashes repeatedly on setup with multiple interfaces.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-network on box with more than 1 interface
2.Make any changes to network device
3.try to apply
    

Actual Results:  neat crashes

Expected Results:  config changes apply

Additional info:

I know, but I just had to create a new one under phoebe for my own record keeping.
Component: redhat-config-network
Version: 1.1.86
Summary: TB /usr/lib/python2.2/site-packages/rhpl/Conf.py:473:__delitem__: KeyEr
ror: optonline.net
 
Traceback (most recent call last):
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 548, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 286, in save
    self.saveProfiles()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 314, in saveProfiles
    profilelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py", l
ine 312, in save
    del hoconf[i]
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 473, in __delitem__
    del self.vars[varname]
KeyError: optonline.net
 
Local variables in innermost frame:
varname: optonline.net
self: <rhpl.Conf.ConfEHosts instance at 0x88a044c>
[tazman@optonline tmp]$ cat neatcrash
Component: redhat-config-network
Version: 1.1.86
Summary: TB /usr/lib/python2.2/site-packages/rhpl/Conf.py:473:__delitem__:
KeyError: optonline.net
 
Traceback (most recent call last):
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 548, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 286, in save
    self.saveProfiles()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 314, in saveProfiles
    profilelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py",
line 312, in save
    del hoconf[i]
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 473, in __delitem__
    del self.vars[varname]
KeyError: optonline.net
 
Local variables in innermost frame:
varname: optonline.net
self: <rhpl.Conf.ConfEHosts instance at 0x88a044c>

Comment 1 Harald Hoyer 2003-01-08 17:19:13 UTC
should be fixed in versions >= 1.1.87

Comment 2 Harald Hoyer 2003-01-13 15:21:41 UTC
new packages to test available at:
ftp://people.redhat.com/harald/redhat-config-network/1.1.87-1/
ftp://people.redhat.com/harald/rhpl/0.74-2/

Comment 3 Bill Nottingham 2003-07-28 21:53:57 UTC
Closing some bugs that have been in MODIFIED for a while. Please reopen if the
problem persists.

Comment 4 Harald Hoyer 2003-08-11 14:08:13 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html


Comment 5 Harald Hoyer 2004-09-21 12:05:41 UTC
*** Bug 97825 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.