Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80592 - redhat-config-kickstart has difficulty importing Anaconda kickstart file
Summary: redhat-config-kickstart has difficulty importing Anaconda kickstart file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-28 15:01 UTC by Peter van Egdom
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 00:44:51 UTC


Attachments (Terms of Use)
Kickstart-file which freaks out redhat-config-kickstart (deleted)
2002-12-28 15:04 UTC, Peter van Egdom
no flags Details
Screenshot showing multiple eth0 problem (deleted)
2002-12-28 15:08 UTC, Peter van Egdom
no flags Details

Description Peter van Egdom 2002-12-28 15:01:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
"redhat-config-kickstart" has difficulties loading my "anaconda-ks.cfg" as
generated by Anaconda during installation.

I'll attach a screenshot and a slightly modified anaconda-ks.cfg (ip adres of my
name server is kept secret, and my encrypted root-password is hidden), loading
this modified anaconda-ks.cfg has exactly the same results as loading the
original anaconda-ks.cfg generated by Anaconda during install of Phoebe.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load the "/root/anaconda-ks.cfg" in redhat-config-kickstart
2.
3.
    

Actual Results: 
 - A lot of errors get returned to the shell (if started redhat-config-kickstart
from an xterm).
- The Network configuration section contains a lot of 'eth0' entries.
  (see attached screenshot)

Expected Results:
  redhat-config-kickstart should accept anaconda-ks.cfg without weird things
happening.

Additional info:

Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 254, in
on_activate_open
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 292, in fillData
    self.X_class.fillData()
  File "/usr/share/redhat-config-kickstart/xconfig.py", line 212, in fillData
    opts, args = getopt.getopt(xList, "d:h", ["noprobe", "card=",
  File "/usr/lib/python2.2/getopt.py", line 72, in getopt
    opts, args = do_longs(opts, args[0][2:], longopts, args[1:])
  File "/usr/lib/python2.2/getopt.py", line 86, in do_longs
    has_arg, opt = long_has_args(opt, longopts)
  File "/usr/lib/python2.2/getopt.py", line 103, in long_has_args
    raise GetoptError('option --%s not recognized' % opt, opt)
getopt.GetoptError: option --card "NVIDIA GeForce 4 (generic)" not recognized
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/network.py", line 139, in
showEditNetworkDialog
    ip1, ip2, ip3, ip4 = string.split(ip, ".")
  File "/usr/lib/python2.2/string.py", line 117, in split
    return s.split(sep, maxsplit)
AttributeError: 'NoneType' object has no attribute 'split'

Comment 1 Peter van Egdom 2002-12-28 15:04:44 UTC
Created attachment 88957 [details]
Kickstart-file which freaks out redhat-config-kickstart

Comment 2 Peter van Egdom 2002-12-28 15:08:54 UTC
Created attachment 88958 [details]
Screenshot showing multiple eth0 problem

Comment 3 Peter van Egdom 2002-12-28 15:10:10 UTC
forgot to tell that described problem occurs on :

redhat-config-kickstart-2.3.5-6
Red Hat Linux release 8.0.92 (Phoebe)


Comment 4 Brent Fox 2003-01-09 20:48:57 UTC
Should be fixed in redhat-config-kickstart-2.3.5-9 in Rawhide.  QA, please verify.

Comment 5 Jay Turner 2003-01-14 19:06:07 UTC
Still seeing an error with reading the video controller designation with
redhat-config-kickstart-2.3.5-9.  Here's the error:

[root@test84 root]# redhat-config-kickstart
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 253, in
on_activate_open
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 291, in fillData
    self.X_class.fillData()
  File "/usr/share/redhat-config-kickstart/xconfig.py", line 212, in fillData
    opts, args = getopt.getopt(xList, "d:h", ["noprobe", "card=",
  File "/usr/lib/python2.2/getopt.py", line 72, in getopt
    opts, args = do_longs(opts, args[0][2:], longopts, args[1:])
  File "/usr/lib/python2.2/getopt.py", line 86, in do_longs
    has_arg, opt = long_has_args(opt, longopts)
  File "/usr/lib/python2.2/getopt.py", line 103, in long_has_args
    raise GetoptError('option --%s not recognized' % opt, opt)
getopt.GetoptError: option --card "NVIDIA GeForce 4 (generic)" not recognized


Comment 6 Brent Fox 2003-01-16 22:55:42 UTC
Ok, Python's getopt isn't nearly as good as popt, which I guess is why anaconda
uses popt instead.  Anyway, this should be fixed with
redhat-config-kickstart-2.3.5-10.  Please test with that as it works for me now.

Comment 7 Jay Turner 2003-01-21 00:44:51 UTC
Fix confirmed with redhat-config-kickstart-2.3.5-10.


Note You need to log in before you can comment on or make changes to this bug.