Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80588 - ACPI is unable to show AC adapter status on HP Omnibook 500
Summary: ACPI is unable to show AC adapter status on HP Omnibook 500
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-28 13:18 UTC by Leonid Kanter
Modified: 2013-07-03 02:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:43 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2002-12-28 13:18:05 UTC
Description of problem:

ACPI is unable to show AC adapter status on HP Omnibook 500

Version-Release number of selected component (if applicable):

2.4.20-2.2

How reproducible:

always

Steps to Reproduce:
1.modprobe ospm_ac_adapter
   
Actual results:

cat /proc/acpi/ac_adapter/0/status always show "Status: on-line", even if laptop
is running on battery power.

Expected results:

/proc/acpi/ac_adapter/0/status must be changed if power cord is pulled off.

Additional info:

APM show battery/power adapter status OK

Comment 1 Gerald Teschl 2003-01-03 20:52:25 UTC
Similar on sony vaio:

Status: off-line

is shown, no matter of the actual status. This works fine with
a stock 2.4.20 + current acpi patch.

Comment 2 Aleksey Nogin 2003-01-06 02:16:05 UTC
Works for me on Dell Lattitude C640 (so far it seems to be the *only* ACPI
feature that does work for me...) - /proc/acpi/ac_adapter/0/status correctly
shows the AC status.

Comment 3 Jeff Garzik 2003-01-17 21:40:32 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.