Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80587 - ACPI is unable to show battery status on HP Omnibook 500
Summary: ACPI is unable to show battery status on HP Omnibook 500
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-28 13:06 UTC by Leonid Kanter
Modified: 2013-07-03 02:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:43 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2002-12-28 13:06:24 UTC
Description of problem:

ACPI is unable to show battery status on HP Omnibook 500

Version-Release number of selected component (if applicable):

2.4.20-2.2

How reproducible:

always

Steps to Reproduce:
1.load ospm_battery module
2.see dmesg output
    
Actual results:

ACPI: Battery socket found, battery absent
ACPI: Battery socket found, battery absent
ACPI: Battery socket found, battery absent

Expected results:

One battery is installed and it must be detected

Comment 1 Gerald Teschl 2003-01-03 20:48:28 UTC
Similar problems on my sony vaio:

ACPI: Battery socket found, battery present
ACPI: Battery socket found, battery present

However, only the first battery is present and the second absent.
Moreover, the values reported by /proc/acpi/battery/{1,2} are bogous.

Using a stock 2.4.20 + latest acpi patch works just fine (with both
one and two batteries present).


Comment 2 Aleksey Nogin 2003-01-06 02:09:43 UTC
When I try doing "modprobe ospm_battery" on my Dell Lattitude C640, I get a
kernel Oops (bug 81124) and an empty /proc/acpi/battery/

Comment 3 Aleksey Nogin 2003-01-06 02:17:36 UTC
Oh, and another thing - Fn-F3 that normally shows the battery status (under grub
and APM kernel) stops working (just does not do anything) as soon as the ACPI
kernel is loaded...

Comment 4 Jeff Garzik 2003-01-17 21:18:36 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.