Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80583 - "copy here" and "link here" of menu entries is the same
Summary: "copy here" and "link here" of menu entries is the same
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-28 10:37 UTC by Michael Schwendt
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-16 14:09:33 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2002-12-28 10:37:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Drag menu entry "Internet > Web Browser" to the desktop and choose "copy here".
A desktop entry will be created in user's $HOME/Desktop directory as a soft-link
(!) to /usr/share/applications/redhat-web.desktop. Since it is just a link and
not a copied file, the user doesn't have write permission to change the
"Properties" of that desktop entry.

Where is the difference to dragging a menu entry to the desktop and choosing
"link here"? It also creates a link to the desktop file in either
/usr/share/applications or /etc/X11/applnk. I would expect "copy here" to
actually _copy_ the *.desktop file rather than soft-linking it. Copying it would
mean the user could edit the "Properties" of his local copy. 

From a usability point of view, it doesn't look right that "copy here" also
creates only a link just like "link here" does already.


Version-Release number of selected component (if applicable):
3.1-0.9

How reproducible:
Always

Comment 1 Michael Schwendt 2004-02-16 14:09:33 UTC
This is fixed in Fedora Core 1.90 (KDE 3.2.0).



Note You need to log in before you can comment on or make changes to this bug.