Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80567 - File imlibgdk.pc from package imlib-devel-1.9.13-9 contains invalid Requires
Summary: File imlibgdk.pc from package imlib-devel-1.9.13-9 contains invalid Requires
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: imlib
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-28 00:54 UTC by Kyle Gonzales
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-24 22:31:51 UTC


Attachments (Terms of Use)

Description Kyle Gonzales 2002-12-28 00:54:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
imlib-devel for Red Hat 8.0 installed a file /usr/lib/pkgconfig/imlibgdk.pc,
which contains the following Requires line:

   Requires: gdk,gmodule

When someone uses pkg-config in the configure script for their program, and they
tell it to look for "imlibgdk", the Requires line in that file tells pkg-config
to find the files gdk.pc and gmodule.pc.  gmodule.pc exists, but gdk.pc does
not.  Therefore, the configure script for their program fails.

Checking thru RHN and the various packages in Red Hat 8.0, there appears to be
NO package that provides the file /usr/lib/pkgconfig/gdk.pc.  Therefore, I
believe either a package in the distribution needs to provide that file, or the
Requires for imlib-devel need to be changed to:

Requires: gdk-2.0,gmodule

as the file /usr/lib/pkgconfig/gdk-2.0.pc does exist, being provided by
gtk2-devel.  I do not know which is correct.  Mine is only to report. ;)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the configure script for a GNOME2 program, like Camorama
(http://camorama.fixedgear.org), which runs pkg-config, and looks for imlibgdk
2. Watch the sparks fly
    

Actual Results:  You get this error:

checking for pkg-config... /usr/bin/pkg-config

checking for gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0 libgnomeui-2.0 gtk+-2.0 >=
1.3.13 gconf-2.0 imlibgdk... Package gdk was not found in the pkg-config search
path.

Perhaps you should add the directory containing `gdk.pc'
to the PKG_CONFIG_PATH environment variable

Package 'gdk', required by 'ImlibGdk', not found

Expected Results:  It should have successfully completed this step, as all other
requirements have been met.

Additional info:

Comment 1 Kyle Gonzales 2002-12-28 02:16:54 UTC
Ah, a slight mistake.  This line:

"Therefore, I believe either a package in the distribution needs to provide that
file, or the Requires for imlib-devel need to be changed to:"

needs to change to:

"Therefore, I believe either a package in the distribution needs to provide the
file gdk.pc, or the Requires line in the file imlibgdk.pc need to be changed to:"

Hope that's not TOO confusing. ;)  Sorry!

Comment 2 Jonathan Blandford 2003-01-24 22:31:51 UTC
it requires gtk+-devel, which did not ship in 8.0 with pc files.  This has been
fixed in Rawhide.  


Note You need to log in before you can comment on or make changes to this bug.