Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80566 - Bad memory caused RH8.0 installation crash
Summary: Bad memory caused RH8.0 installation crash
Keywords:
Status: CLOSED DUPLICATE of bug 27660
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-28 00:43 UTC by P Fudd
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:42 UTC


Attachments (Terms of Use)

Description P Fudd 2002-12-28 00:43:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The install crashed when installing the glibc package.
The problem was that rpm wouldn't install the package due to a bad gpg signature.

However, I did check the cdroms with the built-in media check, and they
passed.

I discovered that I had bad memory up above 127mb, and so small programs would
work, but large ones would fail.  That is to say, I could copy the rpm file to
the hard disk by hand, and run rpm -K on it successfully some of the time.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install bad ram above 128mb
2.Try installing redhat 8.0
3.Pull hair
    

Actual Results:  Installer crash

Expected Results:  Installer crash

Additional info:

I've put 'memtest86' into my grub configuration, and that's how I figured out
what was wrong.

Perhaps you should add memtest86 to the next version of RH Linux, as a boot
option.  After all, you added cdrom testing, memory testing seems a natural
addition.

Comment 1 Michael Lee Yohe 2002-12-30 15:06:08 UTC
There's a different philosophy in testing media versus testing hardware
components.  Media failure can result due to transmission problems (download
process), burning problems (from ISO images), defective discs, et al.  However,
general hardware problems are generally assumed to not exist - Red Hat (as well
as other software manufacturers) could add a ton of additionally utilities for
the ultra-paranoid; however, most of these checks could be performed by the user
(and _should be_) prior to a major software change (OS installation/upgrade).

Comment 2 P Fudd 2002-12-30 21:32:33 UTC
It's true, there is a different philosophy between testing media versus hardware.

However, I'd like my installation programs to be omniscient.  If it dies at
point 'X', I want it to say "check the media, or check your system".  Defense in
depth, or better error messages, or whatever philosophy you want to call it.

As it was, it refused to install the glibc rpm (the first big rpm during a
standard install) but wouldn't say why.  It made me look stupid for choosing
RedHat ("The Operating System That Won't Install") in front of my customer (my
mother).  This led into an educational process where I learned about the signing
of rpms, the checking of rpms (rpm --import keyfile, rpm -K rpmfile.rpm), and
how to install a RedHat system without the benefit of an installation program
(linux rescue).  Then I got to the point where I could download and run
memtest86, and the mystery was solved.

Had anaconda been able to point a finger and say "It's not my fault, it's the
computer's fault", it would have looked better.  I know "Image(tm)" isn't
everything, but it counts for something, doesn't it?  I was trying to show how
easy it was to install Linux, and I think I managed exactly the opposite.

Comment 3 Michael Fulbright 2003-01-02 22:15:04 UTC

*** This bug has been marked as a duplicate of 27660 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.