Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80563 - DELL inspiron fails to shutdown
Summary: DELL inspiron fails to shutdown
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-27 22:34 UTC by Sammy
Modified: 2013-07-03 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:41 UTC


Attachments (Terms of Use)

Description Sammy 2002-12-27 22:34:07 UTC
Since I upgraded to latest rawhide kernels pp.11 and 2.4.20-2.2. 
 
Using shutdown system from kdm login screen, the system goes through 
normal shutdown and finally ends with "System halted" message. No errors 
and everything looks like before. 
 
When I hit the power off button on the Inspiron I get a bunch of cryptic 
messages which ends with oops Kernel panic! and something saying 
"trying to kill init". This is weird because everything is killed and shutdown 
already. Also, among the messages is a list of all the drivers that were 
loaded. Does this mean somehow the modules were not removed and 
the the System halted message is errenous? 
 
Only way I can than power off the system is to disconnect power cable 
and pull out the battery. 	If I then power on again the startup is normal 
i.e. no messages like "system was halted uncleanly" or something like that.

Comment 1 Arjan van de Ven 2002-12-27 23:58:58 UTC
does passing "acpi=off" to the kernel commandline ("a" in grub, or the vmlinuz
line in /boot/grub/grub.conf) fix this ?

Comment 2 Sammy 2002-12-28 13:56:43 UTC
Yes....I added acpi=off to the lilo append line and it fixed the problem. 
Thanks 

Comment 3 Sammy 2003-01-03 14:41:12 UTC
A question about acpi=off. Does this affect the usb/hotplug devices, because since 
I have done this my digital camera is not recognized. I had only a few packages 
updated since than, none seem crucial to this problem. 

Comment 4 Jeff Garzik 2003-01-17 21:39:41 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.