Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80562 - DBD::Mysql doesn't work
Summary: DBD::Mysql doesn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: perl-DBD-MySQL
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
: 79252 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-27 22:31 UTC by Tom Cross
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-09 13:00:15 UTC


Attachments (Terms of Use)

Description Tom Cross 2002-12-27 22:31:41 UTC
Description of problem:
Script that runs fine on RH8.0 with perl-DBD-MySQL doesn't work on Phoebe

Version-Release number of selected component (if applicable):
perl-DBD-MySQL-2.1020-3
perl-DBI-1.32-3
mysql-3.23.52-5

How reproducible:
Run a perl script that attempts to connect to a MySQL Server

Steps to Reproduce:
1. Install perl-DBI, perl-DBD-MySQL, mysql
2. run a script that attempts to connect to a MySQL server
3. boom, crash
    
Actual results:
/usr/bin/perl: relocation error:
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mysql.so:
undefined symbol: mysql_init


Expected results:
It should connect to the database and do happy perly database things.

Additional info:

Comment 1 Chip Turner 2003-01-01 17:57:03 UTC
this is now fixed; please try perl-DBD-MySQL-2.1021-2 from rawhide.

Comment 2 Tom Cross 2003-01-02 15:13:02 UTC
Yes, that new package appears to be working perfectly.

Thanks!

Comment 3 Chip Turner 2003-01-07 04:27:38 UTC
*** Bug 79252 has been marked as a duplicate of this bug. ***

Comment 4 Jay Turner 2003-01-09 13:00:15 UTC
Closing this out on confirmation fix from reporter.


Note You need to log in before you can comment on or make changes to this bug.