Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80553 - last 2 kernel updates don't make it to grub & no img files created
Summary: last 2 kernel updates don't make it to grub & no img files created
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 21:24 UTC by Sean Duffy
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 19:54:35 UTC


Attachments (Terms of Use)

Description Sean Duffy 2002-12-27 21:24:04 UTC
Description of problem:

Loaded 2.4.18 from cd image during standard install which included:
hdc=ide-scsi

Launched up2date and pulled down 2.4.18-14, which installed into grub.

ever since then when up2date indicates new kernel is available:

kernels:
2.4.18-18.8.0
2.4.18-19.8.0

I download and keep hitting Forward until I reach Finished.  Then ...

forever {

  Normal shutdown & reboot.

  New kernels are not available for selection in Grub

  Restart up2date and critical information informs me that my kernel is still
  version 2.4.18-17.8.0 and that I should reboot to test the new kernel.

}

Version-Release number of selected component (if applicable):

up2date-3.0.7.1

How reproducible: 

every kernel update I get through up2date

Steps to Reproduce:

on my system: as described above.  your milage may very.

Actual results:

in /boot I see:

configs for 2.4.18-14, -17.8.0, -18.8.0 & -19.8.0
module-info for 2.4.18-14, -17.8.0, -18.8.0 & -19.8.0
System.nmap for 2.4.18-14, -17.8.0, -18.8.0 & -19.8.0
vmlinux for 2.4.18-14, -17.8.0, -18.8.0 & -19.8.0
vmlinuz for 2.4.18-14, -17.8.0, -18.8.0 & -19.8.0

however for initrd there is only 2.4.18-14 and -17.8.0 (.img)'s

So I know that the img files are never getting made.

If someone can give me a step by step I will check to see what files 
have/have not been updated, and I will provide a more detailed report.

Any suggestions on what to check next sincerely appreciated.

Thanks a 10E6,

Sean


Expected results:


Additional info:

Comment 1 Adrian Likins 2004-08-20 19:54:35 UTC
fixed in more recent releases


Note You need to log in before you can comment on or make changes to this bug.