Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80548 - redhat-config-network crashes if too many aliases on a device
Summary: redhat-config-network crashes if too many aliases on a device
Keywords:
Status: CLOSED DUPLICATE of bug 74989
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 20:39 UTC by Tassos Magoutas
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:40 UTC


Attachments (Terms of Use)

Description Tassos Magoutas 2002-12-27 20:39:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
redhat-config-network crashes if too many aliases on a device.
The following message appears:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/bin/../share/redhat-config-network/netconfpkg/Control.py", line 63,
in __init__
  File "/usr/bin/../share/redhat-config-network/netconfpkg/Control.py", line 66,
in load
OSError: Too many open files

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a lot of aliases for a network device (e.g. 130)
2. Open redhat-config-network
3. After a while (3-5 secs) the program crashes
    

Actual Results:  The program crashed

Additional info:

Comment 1 Harald Hoyer 2003-01-09 14:16:02 UTC

*** This bug has been marked as a duplicate of 74989 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.