Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80544 - Viewing manpages unusable for technical workstation purpose.
Summary: Viewing manpages unusable for technical workstation purpose.
Keywords:
Status: CLOSED DUPLICATE of bug 80847
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-27 20:22 UTC by Peter van Egdom
Modified: 2008-01-17 17:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:40 UTC


Attachments (Terms of Use)
Screenshot of garbled manpage characters (deleted)
2002-12-27 20:36 UTC, Peter van Egdom
no flags Details
ascii screenshot of man problems (deleted)
2003-01-24 15:19 UTC, David Balažic
no flags Details

Description Peter van Egdom 2002-12-27 20:22:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:

Since the introduction of Red Hat 8.0 a lot of manpages are unreadable.

I think this is a i18n issue, but as I see that Phoebe still has this problem I
wanted to
make a bugreport for this against Phoebe, although I know there are already a lot of
open Bugzilla reports of i18n issues.

For any serious technical workstation usage of Red Hat Linux it is *vital* that any
information from - in this case - manpages is 100% readable, and not, as seen in the
attached screenshot, full of weird characters.

For example, I'm playing with SNMP to suck out information from UPS'es and Cisco
switches for monitoring purposes. Of course reading a manpage is really part of the
job when doing this, but for me reading a manpage at the moment is a big undertaking
'an sich' due to translating all strange characters into what they should be.

I really hope that there will be a solution for this problem since I see Red Hat
evolving
into a really important player in the Unix field for the years to come, but this
kind of
problems must really be tackled first.

ps.1.I didn't knew under what package to bugzilla this, "man" looked most
appropriate.
ps.2 I hope that this Bugzilla did not sound too much like a rant.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  "man snmpwalk" in a KDE session.
2.
3.
    

Actual Results:  Some characters in manpages are unrecognisable.

Expected Results:  Manpages should be easy to read

Additional info:

Comment 1 Peter van Egdom 2002-12-27 20:36:02 UTC
Created attachment 88953 [details]
Screenshot of garbled manpage characters

Section A shows that old X apps like xterm have this feature.
Section B shows that new X apps like konsole have this feature.

Comment 2 Peter van Egdom 2003-01-01 15:00:36 UTC
Hmm.. I changed my KDE 'konsole' font to "Lucidatypewriter". With this font the
example I gave with "man snmpwalk" makes at least the manpage a lot more easy to
read. Strange, however, that a default xterm with it's unaliased fonts has
trouble with the - character in "man snmpwalk".

Comment 3 Michael Wardle 2003-01-14 03:51:23 UTC
I reported some problems with the hyphen character ("-") in bug 75193.

I imagine it would be useful to know which man pages are affected in the
same way as snmpwalk(1), whether snmpwalk was provided by a Red Hat package,
and which version of that package you have installed.

I assume your locale or language is set to use Unicode/UTF-8.  What are the
values of LC_ALL and LANG?

I have no authority to ask these questions, I'm just trying to help.  Feel
free to ignore me. :-)



Comment 4 Peter van Egdom 2003-01-14 17:41:34 UTC
Here's some information of my internationalisation settings :

[peterve@powermate peterve]$ cat /etc/sysconfig/i18n 
LANG="nl_NL.UTF-8"
SUPPORTED="nl_NL.UTF-8:nl_NL:nl:en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

If I do a "man ls" in an xterm, I also have the problem of the missing "-"
characters. When I'm doing the same command in a virtual console, the "-"
characters are, however, displayed properly.

The SNMP package is the one supplied with Phoebe "net-snmp-5.0.6-9".

Comment 5 David Balažic 2003-01-24 15:19:11 UTC
Created attachment 89574 [details]
ascii screenshot of man problems

This is what I get with phoebe1 + groff-1.18.1-7 ( the second part is probaly
screen running on VT1, I am not sure ). The hyphens in SYNOPSIS are either
missing or corrupt.

Comment 6 Tim Waugh 2003-01-29 17:27:26 UTC
Looks like the same thing as bug #80847.

*** This bug has been marked as a duplicate of 80847 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.