Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80540 - grub.conf option "root=LABEL=/" causes kernel panic
Summary: grub.conf option "root=LABEL=/" causes kernel panic
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 19:54 UTC by Robert P. J. Day
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-20 09:38:49 UTC


Attachments (Terms of Use)

Description Robert P. J. Day 2002-12-27 19:54:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
  since 7.3, i've been using a kernel line in grub.conf similar
to

 kernel /vmlinux... ro root=LABEL=/ hdb=ide-scsi

having labelled /dev/hda1, my root partition, with the
label "/".

  however, since i upgraded to the red hat updates version
of kernel 2.4.20-2.2, specifying my root filesystem using
"LABEL=/" causes the following at boot time:

 VFS: Cannot open root device "LABEL=/" or 00:00
 Please append a correct "root=" option
 kernel panic: VFS: Unable to mount root fs on 00:00

i can get around this by editing the grub kernel line
and substituting "root=/dev/hda1" and it will boot fine.
but this shouldn't be necessary -- the LABEL option has
worked for quite some time until 2.4.20-2.2.

  i have verified that all of the partitions are still
properly labelled, and unique.  in addition, one other 
participant on the redhat mailing list reported exactly
the same error.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use a "LABEL=/" option in /etc/grub.conf
2. reboot
3.
    

Actual Results:  should boot properly

Expected Results:  kernel panic, see above

Additional info:

Comment 1 Arjan van de Ven 2002-12-27 23:56:17 UTC
does your grub.conf list an initrd ?

Comment 2 Robert P. J. Day 2002-12-28 01:53:54 UTC
  never mind, someone else on the redhat list suggested that it was
the lack of an initrd file that was the problem.  apparently, even
though i had all the modules i needed built into the kernel, the
initrd file was still necessary to be able to use a LABEL option
in grub.conf.  without one, it's necessary to use the explicit device name.

  at least, that's the way it looks, and things work fine now.

Comment 3 Martin O'Connor 2003-05-20 09:22:28 UTC
I can boot a custom redhat kernel without initrd if ext3 is compiled into the
kernel. grub.conf has root=LABEL=/.
The problem occurs with non redhat kernels (eg. fresh download from kernel.org).
Perhaps redhat kernels have a certain configuration default which allows labels
to be read?

Comment 4 Arjan van de Ven 2003-05-20 09:38:49 UTC
the kernel doesn't use this. At all.
you HAVE to have an initrd to use LABEL for root.

Comment 5 Gopu Bhaskar 2004-08-04 09:40:00 UTC
I had ext3 compiled into the kernel but still the problem persisted. 
But removing the root=LABEL=/ itself from grub.conf let my box boot 
fully without any issues.


Note You need to log in before you can comment on or make changes to this bug.