Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80534 - mozilla (Xft enabled) crashes at some sites
Summary: mozilla (Xft enabled) crashes at some sites
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-27 19:31 UTC by Sarantis Paskalis
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-24 04:40:48 UTC


Attachments (Terms of Use)

Description Sarantis Paskalis 2002-12-27 19:31:27 UTC
Description of problem:

mozilla crashes without any indication at some sites (e.g.
http://news.com.com or http://www.zdnet.com).
 
This happens only with the Xft enabled builds of mozilla.  I have tried the
non-Xft builds, and they are working fine.

Version-Release number of selected component (if applicable):
mozilla-1.2.1-3


How reproducible:
Every time

Steps to Reproduce:
1. startup mozilla
2. go to http://news.com.com
3. mozilla crashes 
    
Actual results:


Expected results:


Additional info:

Comment 1 Sarantis Paskalis 2002-12-31 17:08:28 UTC
I searched in the mozilla bugzilla for this bug, and it seems to be 
http://bugzilla.mozilla.org/show_bug.cgi?id=180309

mozilla crashes if a .fon fontfile is in some font directory.  I removed the
.fon files, rebuilt the font list, and now mozilla does not crash anymore
consistently at these sites.  I don't know if there is a "correct" fix for it yet.



Comment 2 Warren Togami 2003-02-22 06:55:38 UTC
One Xft bug in XFree86 was fixed a few days ago that fixed Bug #83354 which was
a Xft related crash in Mozilla.

You had mentioned that you found a potential fix for your problem and/or perhaps
your problem was fixed by the recent Xft patch.  This issue may be resolved.

Comment 3 Christopher Blizzard 2003-02-24 04:40:48 UTC
Yeah, that's the same bug.  Closing since it's filed upstream.


Note You need to log in before you can comment on or make changes to this bug.