Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80530 - (RAID)can't install in a raid device software
Summary: (RAID)can't install in a raid device software
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-27 18:40 UTC by Féliciano Matias
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 02:10:30 UTC


Attachments (Terms of Use)

Description Féliciano Matias 2002-12-27 18:40:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Sorry for my poor english.

My configuration.
hda partition :
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1        21     10552+  83  Linux
/dev/hda2   *        22      8343   4194288    c  Win95 FAT32 (LBA)
/dev/hda3          8344     38981  15441552   83  Linux
/dev/hda4         38982     39507    265104   82  Linux swap

hde partition :
   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *         1        51     25672+  83  Linux
/dev/hde2            52       312    131544   82  Linux swap
/dev/hde3           313      6588   3163104   fd  Linux raid autodetect

hdg partition :
  Device Boot    Start       End    Blocks   Id  System
/dev/hdg1   *         1        51     25672+  83  Linux
/dev/hdg2            52       312    131544   82  Linux swap
/dev/hdg3           313      6588   3163104   fd  Linux raid autodetect

Raid partition :
# cat /proc/mdstat
Personalities : [raid0]
read_ahead 1024 sectors
md0 : active raid0 hdg3[0] hde3[1]
      6326016 blocks 64k chunks
#

/dev/md0 have a ext3 file system formated with RH8.0.

There is a bad detection of raid device (software /dev/md0).

During the installation, disk druid don't detect the ext3 file system in
/dev/md0. Disk Druid give the "foreign" type and not "ext3".

If you don't recreate the md0 device you can't format /dev/md0 and the
installation abort with :

Error :
An error accured trying to format md0. This problem is serious, and the install
cannot continue.

Other message from another console :
mke2fs :
Device size reported to be zero. Invalide partition specified, or partition
table wasn't reread after running fdisk, due to a modified partition being buzy
and in use. You may need to reboot to re-read your partition table.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Phoebe in a system with a raid device (software)
2. Run manual partition with Disk Druid

Actual Results:  Disk Druid don't detect the ext3 file system.

Expected Results:  Disk Druid should detect the ext3 file system.

Additional info:

Here is some kernel message that can help (perhaps there is some mistake !).

<6> [events : 00000011]
<3> md: could not lock hdc3, zero-size ? Marking faulty.
<4> md: could not import hdc3, trying to run array nevertheless.
<6> [events : 9e9c14ca]
<3> md: invalid raid superblock magic on hda3
<4> md: hda3 has invalid sb, not importing !
<4> md: could not import hda3, trying to run array nevertheless.
<6> md: autorun ...
<6> md: considering hde3 ...
<6> md: add hde3
<6> md: created md0
<6> md: bind <hde3,1>
<6> md: running : <hde3>
<6> md: hde3's event counter : 00000011
<4> md: device name has changed from hdc3 to hde3 since last import !
<4> md0: former device hda3 is unavailable, removing from array !
<6> md0: max total readahead window set to 512 k
<6> md0: 2 data-disks, max readahead per data-disk : 256 k
<3> md: md0, array needs 2 disks, has 1, aborting.
<4> raid0: disks are not ordored, aborting!
<3> md: pers->run() failed ...
<4> md: do_md_run() returned _22
<6> md: md0 stopped
<6> md: unbind <hde3,0>
<6> md: export_rdev(hde3)
<6> md: ... autorun DONE.

Comment 1 Féliciano Matias 2002-12-27 19:05:49 UTC
I also have some problems with RH8.0 and raid device but don't invertigate.

Comment 2 Féliciano Matias 2002-12-29 17:36:56 UTC
I do one install with hard disk mode (text mode) and don't see this bug.

Comment 3 FRLinux 2002-12-31 12:49:32 UTC
I saw the same behavior where phoebe was unable to correctly detect my raid0
partition. I wasn't installing on it though as i had /dev/hda6 free for this.
But that's only after a kernel recompilation that i could access my data on
/dev/md0, before it kept telling me that it wasn't an ext3 fs.

Here's my partitionning : 

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1         3     24066   83  Linux
/dev/hda2   *         4       258   2048287+   6  FAT16
/dev/hda3           259      5994  46074420   fd  Linux raid autodetect
/dev/hda4          5995      7299  10482412+   5  Extended
/dev/hda5          5995      6504   4096543+  83  Linux
/dev/hda6          6505      7014   4096543+  83  Linux
/dev/hda7          7015      7299   2289231   83  Linux

   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1   *         1      8126   4095472+  83  Linux
/dev/hdc2          8127      8938    409248   82  Linux swap
/dev/hdc3          8939    100366  46079712   fd  Linux raid autodetect
/dev/hdc4        100367    116336   8048880    5  Extended
/dev/hdc5        100367    109509   4608040+  83  Linux


Comment 4 Féliciano Matias 2004-09-30 02:10:30 UTC
Never see this bug again.
Close it.


Note You need to log in before you can comment on or make changes to this bug.