Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80512 - Mouse malfunctioning at end install and in X
Summary: Mouse malfunctioning at end install and in X
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-27 15:01 UTC by Jos Vos
Modified: 2008-01-17 17:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:54:10 UTC


Attachments (Terms of Use)

Description Jos Vos 2002-12-27 15:01:39 UTC
Description of problem:
When the installation of the packages is completed, the mouse does only appear
at the borders and can't be moved to the buttons etc. on the screen. So, the
questions about bootdiskette, X configuration, etc. can only be answered via
tab/arrow keys. The mouse worked fine before the package install and also
afterwards, when the system is booted.

Version-Release number of selected component (if applicable):
anaconda 8.0.92

How reproducible:
The system is a Supermicro P45BE mainboard with a PS/2 mouse attached.

Comment 1 Michael Fulbright 2002-12-27 16:35:10 UTC
Bill could this be something that happened when we run kudzu in post-install?

Comment 2 Jos Vos 2002-12-27 16:47:46 UTC
I installed for the 2nd time on another system (same type) with exactly the same
problem, so it's fully reproducable for me now.  The weird thing is that the
mouse works fine for the rest of the time.

Comment 3 Bill Nottingham 2002-12-30 06:37:04 UTC
msf: Yes. This is because Matt made me change the type of mouse reported to
anaconda, saying that anaconda would have to be fixed.

I presume this is an wheelmouse of some sort?

Comment 4 Jos Vos 2002-12-30 07:05:41 UTC
No, it's an ordinary 3-button Logitech (OEM) PS/2 mouse.

Comment 5 Jos Vos 2002-12-30 11:22:41 UTC
Bad news: the mouse is not functioning well in normal X mode too.

It is sometimes usable for a few seconds (not more...) and then it jumps to the
border of the screen.  I can drag it back to function normally then, but it
stays trying to jump to the borders :-(.

FWIW, these are the contents of /etc/sysconfig/mouse (as filled in by Anaconda):

FULLNAME="Generic - 3 Button Mouse (PS/2)"
MOUSETYPE="ps/2"
XEMU3="no"
XMOUSETYPE="generic3ps/2"
DEVICE=/dev/psaux
OPTIONS="-t imps2 -m /dev/input/mice -M"

Comment 6 Bill Nottingham 2002-12-30 20:23:02 UTC
Woops, I'm not sure unilaterally mapping generic3ps2 to imps2 is right. Hm, time
to get some more mice and test.

Comment 7 John Murga 2003-01-07 10:10:46 UTC
I had similar problems, disabling gpm seemed to get around it...

Comment 8 Jos Vos 2003-01-07 10:33:08 UTC
Indeed: stopping gpm makes the problem disappear (in normal X mode, dunno what's
causing the problems in Anaconda). Can I try another value for OPTIONS in
/etc/sysconfig/mouse?

Comment 9 Jeremy Katz 2003-01-10 06:33:15 UTC
This was caused by redhat-config-mouse doing service gpm restart instead of
condrestart when it was called by kudzu in our post-install.  Fixed in newer
redhat-config-mouse

Comment 10 Brent Fox 2003-05-25 14:54:10 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.