Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80502 - crashes with "unknown error"
Summary: crashes with "unknown error"
Keywords:
Status: CLOSED DUPLICATE of bug 80283
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 11:50 UTC by Gilbert Fernandes
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:37 UTC


Attachments (Terms of Use)

Description Gilbert Fernandes 2002-12-27 11:50:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I have upgraded my Red Hat 8.0 to Phoebe yesterday.
I tried to launch the package manager, I type the root password and then it
crashes with an "unknown error" message. Launching it from an xterm seems much
more verbose :

[gilb@glinux gilb]$ redhat-config-packages
 
(MainWindow.py:6682): GLib-GObject-WARNING **: invalid uninstantiatable type `gi
nt' in cast to `GtkObject'
 
(MainWindow.py:6682): GLib-GObject-WARNING **: instance of invalid non-instantia
table type `gint'
 
(MainWindow.py:6682): GLib-GObject-CRITICAL **: file gsignal.c: line 2056 (g_sig
nal_handlers_destroy): assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

I am gonna save my files, and try a full install of Phoebe instead to see if
this comes from the update, rather than Phoebe itself.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Red Hat 8.0 + upgrade to Phoebe
2. Xterm + "redhat-config-packages" (I do this as root)
3. See message above
    

Actual Results:  assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

Expected Results:  Launch of package manager.

Additional info:

Machine is a casual i386.
Been running Red Hat 8 since it went out.
Everything is standard there: kernel, everything.
I just use Open Office to write articles with it, Mozilla and Gimp.
Nothing else.

Comment 1 Jeremy Katz 2002-12-27 17:17:56 UTC

*** This bug has been marked as a duplicate of 80283 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.