Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80500 - vestigial cursor appears where it no longer is
Summary: vestigial cursor appears where it no longer is
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gtk2
Version: phoebe
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-27 10:52 UTC by Fred New
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 15:36:13 UTC


Attachments (Terms of Use)

Description Fred New 2002-12-27 10:52:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I sometimes see a (non-blinking) vertical bar indicating the location of the
cursor where it isn't.  At the same time, there will be a blinking vertical bar
where the cursor actually is.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start gedit.
2. Copy the following lines into the gedit area (the text on the first line
needs to wrap at least twice):

Note: If you need to enter large amounts of text such as logfiles, sample code,
patches, etc. then please submit them as an attachment to this bug instead of
placing them in the description field.  This sentence is added to make the line
long enough to wrap twice when viewed using Nautilus.
New line - this is actually line 2. The previous line wrapped a few times.

3.  Press <Home> and use the arrow keys to move the cursor to the top of the
area and then move to the bottom of the area.

Actual Results:  I see a non-blinking, vertical line at the beginning of the
last line of the wrapped line and a blinking vertical line at the beginning of
the last line, where it is supposed to be.

Expected Results:  I expect to see the only the blinking vertical line to
indicate where the cursor actually is.

Additional info:

I suspect this is a problem with gtk+/GtkTextView, since I also see this problem
when I save the above file and view it with Nautilus.

The following bug at gnome.org appears to describe the same problem:
http://bugzilla.gnome.org/show_bug.cgi?id=72374

Comment 1 Owen Taylor 2003-01-09 19:38:47 UTC
Unlikely to fix this stream before it is fixed upstream.

Comment 2 Owen Taylor 2003-01-15 22:25:25 UTC
Added a tentative patch to the GNOME bugzilla bug.


Comment 3 Owen Taylor 2003-02-03 15:36:13 UTC
Should be fixed in gtk2-2.2.1


Note You need to log in before you can comment on or make changes to this bug.