Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80490 - won't re open files in simple program
Summary: won't re open files in simple program
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libstdc++
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 05:40 UTC by Need Real Name
Modified: 2015-01-08 00:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-17 17:25:32 UTC


Attachments (Terms of Use)
sample code (deleted)
2002-12-27 05:44 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-12-27 05:40:40 UTC
Description of problem:
In a simple do ...while loop program to open a file as many times as the user 
wants, Red Hat 8.0 will not open the file more than once.  It worked in 7.3, 
so it appears that I am missing part of a new update , or something is missing.

Thanks,
Tom

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. compile and execute (see code and typescript below)
2.
3.
    
Actual results:
on second loop through program, fails to open source file

Expected results: expected it to open source file


Additional info:

Comment 1 Need Real Name 2002-12-27 05:44:50 UTC
Created attachment 88938 [details]
sample code 

sample output:

[Tom@localhost Tom]$ ./a.out
Opening file a.dat
abcdef
repeat? (y/n): n y
Opening file a.dat
failed to open.

repeat? (y/n): y
Opening file a.dat
failed to open.

repeat? (y/n): n
bye.

Comment 2 Jens Petersen 2003-01-15 17:37:50 UTC
Assigning to libstdc++ component, since your example is in C++.

Comment 3 Benjamin Kosnik 2003-01-17 17:21:00 UTC
This is a change in behavior, but is not a bug. Please read this:

http://gcc.gnu.org/onlinedocs/libstdc++/faq/index.html#4_4_iostreamclear


Note You need to log in before you can comment on or make changes to this bug.