Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80488 - ehci-hcd (USB) doesn't work
Summary: ehci-hcd (USB) doesn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
: 81038 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-27 04:37 UTC by Brian C. Huffman
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-12 22:01:20 UTC


Attachments (Terms of Use)

Description Brian C. Huffman 2002-12-27 04:37:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I've seen this in rawhide for a little while now and it appears that
it's also in Phoebe.  The default USB host controller driver will not
load correctly.  This is what it says on bootup:

/lib/modules/2.4.20-2.2/kernel/drivers/usb/hcd/ehci-hcd.o.gz:
init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-2.2/kernel/drivers/usb/hcd/ehci-hcd.o.gz: insmod
/lib/modules/2.4.20-2.2/kernel/drivers/usb/hcd/ehci-hcd.o.gz failed
/lib/modules/2.4.20-2.2/kernel/drivers/usb/hcd/ehci-hcd.o.gz: insmod
ehci-hcd failed


And then in /var/log/messages:

Dec 26 23:30:11 oveja kernel: PCI: Found IRQ 10 for device 00:1d.7
Dec 26 23:30:11 oveja kernel: hcd.c: ehci-hcd @ 00:1d.7, Intel Corp.
82801DB USB EHCI Controller
Dec 26 23:30:11 oveja kernel: hcd.c: irq 10, pci mem e4c0cc00
Dec 26 23:30:11 oveja kernel: usb.c: new USB bus registered, assigned
bus number 4
Dec 26 23:30:11 oveja kernel: hcd.c: remove: 00:1d.7, state 0
Dec 26 23:30:11 oveja kernel: usb.c: USB bus 4 deregistered

Of course devices that used to work in 8.0 don't work.  I would assume
it's due to this problem.

This is on an Intel 845GBV motherboard.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system
2. ehci-hcd fails to load
3. done
    

Actual Results:  ehci-hcd fails to load and USB devices do not work.

Expected Results:  ehci-hcd loads and USB devices work as expected.

Additional info:

Comment 1 Brian C. Huffman 2002-12-31 05:09:07 UTC
Well...I got it to work!  sort of.... the ACPI stuff didn't do it - but
I've left it in.  I got the latest ehci-hcd patches from bitkeeper on
ftp.kernel.org and applied them.  I'm pretty sure that's what fixed it -
although in the process I've also update the hotplug rpms and added some
patches to usbdevio and usb-uhci.  So, I'm not sure what actually fixed
it.  :-(  I do know that after I applied the ehci-hcd patches all the
errors went away - but it still didn't find my USB device (camera).  

So here's the interesting part.  When I installed the latest hotplug
rpms, it adds a startup script that pretty much does the same USB module
loads that the stock RH scripts do.  However if I do a stop and restart
using this script, voila!  All of a sudden it sees hardware attached to
the bus.  The only difference that I can see is the order in which
things are done.  RedHat loads usbcore and then the controller modules
(ehci-hcd, usb-uhci) and then mounts the usbfs.  The hotplug rpms load
usbcore, mount usbfs and *then* load the HCDs....  Go figure.  

Comment 2 Bill Nottingham 2003-01-06 21:30:22 UTC
*** Bug 81038 has been marked as a duplicate of this bug. ***

Comment 3 Joe Ceklosky 2003-01-07 15:24:02 UTC
The recent 2.4.21-pre3 fixes this issue on the Intel motherboards.
Please pick up the recent patches.

Comment 4 Arjan van de Ven 2003-01-12 22:01:20 UTC
yeah they should be in rawhide already


Note You need to log in before you can comment on or make changes to this bug.