Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80474 - Please add multihead configuration to redhat-config-xfree86
Summary: Please add multihead configuration to redhat-config-xfree86
Keywords:
Status: CLOSED DUPLICATE of bug 74132
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 00:57 UTC by Bjorn Jorgensen
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:36 UTC


Attachments (Terms of Use)

Description Bjorn Jorgensen 2002-12-27 00:57:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207
Phoenix/0.5

Description of problem:
Red hat 8.1 beta1 (i386) and rh 8.0 did not find my 2.nd monitor, and my 2.nd
video device. 

# File generated by anaconda.

Section "ServerLayout"
	Identifier     "Anaconda Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Mouse1" "SendCoreEvents"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "dri"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"
#	Option	"AutoRepeat"	"500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
#	Option	"Protocol"	"Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
	#Option	"XkbOptions"	""
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc102"
	Option	    "XkbLayout" "no"	#Option	"XkbVariant"	""
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
	Identifier  "Mouse1"
	Driver      "mouse"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "IMPS/2"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	HorizSync    30.0 - 96.0
	VertRefresh  50.0 - 160.0
	Option	    "dpms"
EndSection

Section "Device"
	# no known options
        #BusID
	Identifier  "Voodoo5 (generic)"
	Driver      "tdfx"
	VendorName  "Voodoo5 (generic)"
	BoardName   "Voodoo5 (generic)"
	VideoRam    65536
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Voodoo5 (generic)"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Mode         0666
EndSection


this is my xfree file. 

but I do also have 

Section "Monitor"
    Identifier "monitor2"
    VendorName "Plug'n Play"
    ModelName "TVM TCO6S Model"
    HorizSync 30.0-69.0
    VertRefresh 50.0-120.0 
and 

Section "Device"
    Identifier "device2"
    VendorName "Matrox"
    BoardName "Matrox Mystique"
    Driver "mga"
    Screen 0
    BusID "PCI:2:1:0"
    Option "DPMS"
EndSection

In this "hardware" program in x I found the matrox card, but not in the xfree
file?? 





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.what
2.ever
3.??
    

Additional info:

Comment 1 Mike A. Harris 2002-12-27 04:04:38 UTC
Xconfigurator no longer exists in Red Hat Linux.  Reassigning to
redhat-config-xfree86.

The config tool does not support multihead configuration currently, so this
is really more of a feature request.  Changing to an enhancement request for
dualhead configuration.

Comment 2 Brent Fox 2003-01-02 17:10:19 UTC

*** This bug has been marked as a duplicate of 74132 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.