Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80470 - Internal compier error when building binutils.2.13.1
Summary: Internal compier error when building binutils.2.13.1
Keywords:
Status: CLOSED DUPLICATE of bug 75415
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-27 00:32 UTC by Chris Hakimi
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:36 UTC


Attachments (Terms of Use)

Description Chris Hakimi 2002-12-27 00:32:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On an Intel PIII box, running RedHat 8.0, I've installed binutils.2.13.1 
from ftp://ftp.gnu.org/pub/ftp.
After download, I created a build directory ('build'), changed directory to the
build directory and executed:

$ ../binutils.2.13.1/configure --target=powerpc-eabi --prefix=/apps -v

Next I executed the following command:

$ make all

And got the following error:
---------------------------------
Making all in po
make[3]: Entering directory `/u03/CrossGCC/binutils/gas/po'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/u03/CrossGCC/binutils/gas/po'
make[3]: Entering directory `/u03/CrossGCC/binutils/gas'
gcc -DHAVE_CONFIG_H -I. -I../../binutils-2.13.1/gas -I. -D_GNU_SOURCE -I.
-I../../binutils-2.13.1/gas -I../bfd -I../../binutils-2.13.1/gas/config
-I../../binutils-2.13.1/gas/../include -I../../binutils-2.13.1/gas/..
-I../../binutils-2.13.1/gas/../bfd -I../../binutils-2.13.1/gas/../intl -I../intl
-DLOCALEDIR="\"/apps/tools/share/locale\""   -W -Wall -Wstrict-prototypes
-Wmissing-prototypes -g -O2 -c ../../binutils-2.13.1/gas/config/tc-ppc.c
../../binutils-2.13.1/gas/config/tc-ppc.c: In function `md_assemble':
../../binutils-2.13.1/gas/config/tc-ppc.c:2188: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2190: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2195: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2197: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2202: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2204: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2209: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:2211: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c: In function `md_apply_fix3':
../../binutils-2.13.1/gas/config/tc-ppc.c:5404: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:5411: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:5418: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:5425: warning: right shift count >=
width of type
../../binutils-2.13.1/gas/config/tc-ppc.c:5553: Internal compiler error in
simplify_subreg, at simplify-rtx.c:2452
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [tc-ppc.o] Error 1
make[3]: Leaving directory `/u03/CrossGCC/binutils/gas'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/u03/CrossGCC/binutils/gas'
make[1]: *** [all-recursive-am] Error 2



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. as noted above. download 'binutils.2.13.1' from ftp.gnu.org/pub/gnu
2. unzip, untar binutils.2.13.1.tar file
3. create build directory, change directory to build directory
4. execute:
$ ../binutils-2.13.1/configure --target=powerpc-eabi --prefix=/apps -v

    

Actual Results:   


Expected Results:  successful build of binutils 

Additional info:

Comment 1 Jakub Jelinek 2002-12-27 11:59:52 UTC

*** This bug has been marked as a duplicate of 75415 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.