Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80463 - Installer states "unhandled exception" just before installing to hard drives
Summary: Installer states "unhandled exception" just before installing to hard drives
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 21:07 UTC by Harold P. Hjalmarson
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-29 22:37:08 UTC


Attachments (Terms of Use)

Description Harold P. Hjalmarson 2002-12-26 21:07:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)

Description of problem:
The system hangs in util.py  I cannot use the floppy disk option to capture the bug report. 



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Actual Results:  hung system

Expected Results:  Disk activity indicating that the installation is proceediing.

Additional info:

The last linesin the final window  are the following.

File "/usr/lib/anaocnda/util.py", line 66, in execwithRedirect childpid = os.fork()

OSError: [errno 12] Cannot allocate memory

I had planned to do a server install.  Then I went back to change it to a custom install.  This change deleted all the partioning so I had to re-enter all that information.

I noticed that the earlier lines captured in the final window refer to partitions.py and to meta-deletes.

When I reinstall, I won't change my mind about which type to system to install.  I expect that I won't have another hung installation.

Comment 1 Michael Fulbright 2002-12-27 16:24:30 UTC
How much RAM is in your system? 64MB is required.

Comment 2 Harold P. Hjalmarson 2002-12-28 21:03:50 UTC
Thanks for responding. 

I have exactly 64 MB of RAM in the computer.  It is slower than it was with 
Redhat 7.2; thus I probably will buy some more RAM for it.

I successfully installed Redhat 8.0 on my second attempt.

I also note that in both attempts I had tried to mount hdb as /home.  However, 
this mount did not occur probably because the installer made /home on hda 
(there were no error messages).  Later I did a rename to mount hdb as /home.  

I mention this in case it has some relevance to the installer hangup in the 
first attempt. 

Comment 3 Jeremy Katz 2002-12-29 22:37:08 UTC
We've bumped where the amount of RAM needed before turning on swap "early" in
rawhide, so this shouldn't be as much of a problem in future releases.


Note You need to log in before you can comment on or make changes to this bug.