Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80462 - adduser don't allow '.' in user name
Summary: adduser don't allow '.' in user name
Keywords:
Status: CLOSED DUPLICATE of bug 89205
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils
Version: 9
Hardware: athlon
OS: Linux
high
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 20:58 UTC by Féliciano Matias
Modified: 2007-03-27 03:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:36 UTC


Attachments (Terms of Use)
work around for but (deleted)
2003-05-14 20:12 UTC, Ed Ellefsen
no flags Details

Description Féliciano Matias 2002-12-26 20:58:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
adduser don't allow char '.' in user name

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-3

How reproducible:
Always

Steps to Reproduce:
As root :
# adduser f.matias
adduser: invalid user name 'f.matias'
#

Same problem with firstboot. With firstboot add the user 'f.matias' (for
example) and you get :
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 336, in nextClicked
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/create_user.py", line 141, in apply
    self.admin.addUser(userEnt)
RuntimeError: name contains invalid char `.'


Actual Results:  Don't work.

Expected Results:  user with a char '.' added.

Additional info:

Comment 1 Ed Ellefsen 2003-05-14 20:12:21 UTC
Created attachment 91682 [details]
work around for but

Can use newusers utility to add users with perion (".") in user name.

Comment 2 Milan Kerslager 2003-10-23 04:01:32 UTC
The bug #89205 has a working patch for this problem. I did not check firstboot.

*** This bug has been marked as a duplicate of 89205 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.