Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80455 - mrtg does not create graphs, it gives error messages at startup
Summary: mrtg does not create graphs, it gives error messages at startup
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mrtg
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL: //195.241.126.114/mrtg/index.html
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 19:49 UTC by Jan Gerrit Kootstra
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-17 08:31:51 UTC


Attachments (Terms of Use)

Description Jan Gerrit Kootstra 2002-12-26 19:49:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Data files are create, but it does not create any graphs.

The error messages are:

gd-png:  fatal libpng error: Invalid filter type specified
gd-png error: setjmp returns error condition

These messages are repeated several times.

The /etc/mrtg/mrtg.cfg worked fine for RH Linux 7.3

The /etc/mrtg/mrtg.cfg file:

# Multi Router Traffic Grapher -- Example Configuration File
######################################################################
# This file is for use with mrtg-2.0
#
# Note:
#
# * Keywords must start at the begin of a line.
#
# * Lines which follow a keyword line which do start
#   with a blank are appended to the keyword line
#
# * Empty Lines are ignored
#
# * Lines starting with a # sign are comments.

# Where should the logfiles, and webpages be created?

# Minimal mrtg.cfg
#--------------------

RunAsDaemon: No


IconDir: /icons/
WorkDir: /var/www/html/mrtg
PathAdd: /usr/bin

Target[disk3]: `/usr/local/scripts/disk_space.pl 0 1`
XSize[disk3]: 350
Title[disk3]: Disk usage for ci2951.rtd.civility.nl
MaxBytes[disk3]: 100
Options[disk3]: gauge, growright
YLegend[disk3]: %
ShortLegend[disk3]: %
Legend1[disk3]: Diskspace used
Legend2[disk3]: Diskspace used
LegendI[disk3]: /:
LegendO[disk3]: /boot:
PageTop[disk3]: <H1>Disk usage for ci2951.rtd.civility.nl</H1>

Target[localhost.mem]: `free -bt | grep buffers\/cache | awk '{print
$3"\n"$4}'`MaxBytes[localhost.mem]: 201326592
Title[localhost.mem]: Memory Utilization for ci2951.rtd.civility.nl
PageTop[localhost.mem]: <H1>Memory Utilization for ftp.cimplex.nl </H1>
Options[localhost.mem]: gauge,growright
YLegend[localhost.mem]: Bytes
ShortLegend[localhost.mem]: B
Legend1[localhost.mem]: Internal memory
Legend2[localhost.mem]: Buffers + Cache
Legend3[localhost.mem]: Maximal 5 Minute Memory In Use
Legend4[localhost.mem]: Maximal 5 Minute Active Memory
LegendI[localhost.mem]:  Used:
LegendO[localhost.mem]:  Buffers + Cache:
XSize[localhost.mem]: 350

XSize[localhost_users]: 350
Title[localhost_users]: Number of Users / Processes
Target[localhost_users]: `/usr/local/scripts/users.pl`
Options[localhost_users]: gauge,absolute,integer,nopercent,growright
MaxBytes[localhost_users]: 100000
YLegend[localhost_users]: Users / Processes
ShortLegend[localhost_users]: Users / Processes
Legend1[localhost_users]: Number of users
Legend2[localhost_users]: Number of processes
LegendI[localhost_users]: u:
LegendO[localhost_users]: p:
PageTop[localhost_users]: <h1>Number of Users / Processes</h1>

Title[http]: HTTP & QMail Connections
XSize[http]: 350
Target[http]: `/usr/local/scripts/connect_www_qmail.sh`
Options[http]: gauge,absolute,integer,nopercent,growright
MaxBytes[http]: 100000
YLegend[http]: Connections
ShortLegend[http]: Connections
Legend1[http]: Number of HTTP connections
Legend2[http]: Number of Qmail connections
LegendI[http]: HTTP connection:
LegendO[http]: QMail connections:
PageTop[http]: <h1>HTTP & QMail Connections</h1>


The necessary scripts are downloaded form the link pages of www.mrtg.cfg.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install mrtg
2. Install the necessary scripts or install net-snmpd and create another
/etc/mrtg/mrtg.cfg with cfgmaker
3. indexmaker /etc/mrtg/mrtg.cfg > /var/www/html/mrtg/index.html
4. mrtg /etc/mrtg.cfg

Actual Results:  error messages appear

Expected Results:  png format pictures being created viewable with a web-browser
like netscape 7.0 or mozilla 1.x

Additional info:

The used software rpm's:

mrtg-2.9.25-1.7.2
gd-1.8.4-9
libpng-1.2.2-6

Comment 1 Miloslav Trmač 2004-08-17 08:31:51 UTC
I can't reproduce this with mrtg-2.10.5, please reopen
if the error still occurs with a recent mrtg package.


Note You need to log in before you can comment on or make changes to this bug.