Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80452 - Anaconda's bootloader configuration doesn't detect Windows XP
Summary: Anaconda's bootloader configuration doesn't detect Windows XP
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-26 19:39 UTC by Peter van Egdom
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-27 22:33:24 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2002-12-26 19:39:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:

During installation of Red Hat Linux release 8.0.92 (Phoebe) I noticed that
Anaconda's
bootloader configuration did not detect the presence of Windows XP on my harddrive.

The solution for me was to just to do "Add" and point to "/dev/hda1".


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Phoebe (RH 8.0.92) on a system with Windows XP.
2. Observe the bootloader config screen.
3.
    

Actual Results:
  Anaconda did not detect Windows XP.

Expected Results:
  Anaconda should've detected Windows XP and put it automatically in the
bootloader menu.

Additional info:

Red Hat Linux release 8.0.92 (Phoebe)

Comment 1 John J. Germs 2003-01-01 01:56:27 UTC
Experienced the same with a Win2K install on a 2nd HD.
Tried two seperate installs (one with Grub and one with LILO)
setting it manually as /dev/hdb1 with no success in booting
the 2K install.

I'm not new to Linux so I suspected it would have difficulty, but
I just had to try.  ;)

If everything worked perfect that 2K install would be bye bye anyways.. heh.

Comment 2 Thomas M Steenholdt 2003-01-22 22:35:57 UTC
Same results here - the bootloader configurator did find and configure an entry
for an unbootable extended DOS partition though.
Yes i AM aware that it will be very difficult to check if a device is actually
bootable, i'm only hinting at; if the configuration can find a configure an
entry for a vfat device, it really shouldn't be that hard to add the ability to
do the same for any NTFS devices, or...? Instead of DOS call it WINDOWS

Comment 3 Thomas M Steenholdt 2003-01-22 22:36:36 UTC
Oh and the above is with Phoebe .93

Comment 4 Jeremy Katz 2003-01-23 00:22:52 UTC
Fixed in CVS.  An update disk for 8.0.93 is available from
http://people.redhat.com/~katzj/phoebe-update.img with the fix.

Comment 5 Peter van Egdom 2003-02-27 22:33:24 UTC
Confirmed fixed in Phoebe 8.0.94.
Resolving bug with resolution "CURRENTRELEASE"
Thanks!



Note You need to log in before you can comment on or make changes to this bug.