Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80434 - compiling the kernel from src.rpm fails
Summary: compiling the kernel from src.rpm fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 09:48 UTC by Marian-Nicolae ION
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-27 12:50:12 UTC


Attachments (Terms of Use)

Description Marian-Nicolae ION 2002-12-26 09:48:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20021120
Netscape/7.01

Description of problem:
Trying to recompile the packages of the new kernel kernel-2.4.18-19.8 from its
source package kernel-2.4.18-19.8.0.src.rpm fails with:

Patch #1600 (linux-2.4.18-procfixes.patch):
+ patch -p1 -s
1 out of 1 hunk FAILED -- saving rejects to file drivers/net/natsemi.c.rej

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download kernel-2.4.18-19.8.0.src.rpm
2. install it with rpm -ivh kernel-2.4.18-19.8.0.src.rpm
3. rpmbuild -ba kernel-2.4.spec

    

Actual Results:  Patch #1600 (linux-2.4.18-procfixes.patch):
+ patch -p1 -s
1 out of 1 hunk FAILED -- saving rejects to file drivers/net/natsemi.c.rej



Expected Results:  to continue the normal compilation...

Additional info:

drivers/net/natsemi.c.rej:
*** 1963,1968 ****
                if (copy_from_user(&eeprom, useraddr, sizeof(eeprom)))
                        return -EFAULT;

                if ((eeprom.offset+eeprom.len) > NATSEMI_EEPROM_SIZE) {
                        eeprom.len = NATSEMI_EEPROM_SIZE-eeprom.offset;
                }
--- 1963,1971 ----
                if (copy_from_user(&eeprom, useraddr, sizeof(eeprom)))
                        return -EFAULT;

+               if (eeprom.offset > eeprom.offset+eeprom.len)
+                       return -EINVAL;
+
                if ((eeprom.offset+eeprom.len) > NATSEMI_EEPROM_SIZE) {
                        eeprom.len = NATSEMI_EEPROM_SIZE-eeprom.offset;
                }

Comment 1 Arjan van de Ven 2002-12-26 17:09:31 UTC
this is extremely strange since the binaries we ship get build from the exact
same .src.rpm... are you 100% sure the kernel patches are ALL unchanged?


Comment 2 Marian-Nicolae ION 2002-12-27 12:50:12 UTC
I've downloaded again the src.rpm and I've cleaned the SOURCES directory and
now it compiles OK.


Note You need to log in before you can comment on or make changes to this bug.