Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80433 - rh-cfg-date does not startup
Summary: rh-cfg-date does not startup
Keywords:
Status: CLOSED DUPLICATE of bug 80432
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 09:21 UTC by Tassos Magoutas
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:35 UTC


Attachments (Terms of Use)

Description Tassos Magoutas 2002-12-26 09:22:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When trying to execute redhat-config-date the program crashes and the following
error is being displayed:


Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open console and type 'redhat-config-date'
2.Press enter to execute it.
3.Alternatively you may use: Start->System Setting->Date & Time
    

Additional info:

It might be related to timezones configuration.
When I give 'date' I get back something like 
Thu Dec 26 11:19:53 GMT+2 2002
That seems right since the local timezone is GMT+2
But when I receive e-mail from the server using a client then the system adds 4
hours to the actual receive time of each message

Comment 1 Brent Fox 2002-12-26 16:24:24 UTC

*** This bug has been marked as a duplicate of 80432 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.