Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80429 - kudzu segfaults immediately on startup in parallelProbe()
Summary: kudzu segfaults immediately on startup in parallelProbe()
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-26 07:49 UTC by Nathan Bryant
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-22 22:54:14 UTC


Attachments (Terms of Use)
/proc/sys/dev/parport/parport0/autoprobe (deleted)
2003-01-01 01:42 UTC, Nathan Bryant
no flags Details

Description Nathan Bryant 2002-12-26 07:49:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
kudzu does this every time i run it on this machine, whether or not the printer
is turned on when kudzu is invoked.

Program received signal SIGSEGV, Segmentation fault.
0x4207a4f3 in strlen () from /lib/i686/libc.so.6
(gdb) bt
#0  0x4207a4f3 in strlen () from /lib/i686/libc.so.6
#1  0x08059548 in readProbeInfo ()
#2  0x08059710 in parallelProbe ()
#3  0x08051ad4 in probeDevices ()
#4  0x0804fb40 in main ()
#5  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
(gdb)

Version-Release number of selected component (if applicable):
kudzu-0.99.69-1

How reproducible:
Always

Steps to Reproduce:
1. just type "kudzu" on my machine, while su'ed to root
2.
3.
    

Actual Results:  see above

Expected Results:  not like above

Additional info:

machine was upgraded from 7.3

Comment 1 Bill Nottingham 2002-12-30 06:32:03 UTC
Cute, can you attach /proc/sys/dev/parport/parport*/autoprobe?

Comment 2 Nathan Bryant 2003-01-01 01:42:14 UTC
Created attachment 89020 [details]
/proc/sys/dev/parport/parport0/autoprobe

Comment 3 Bill Nottingham 2003-02-20 03:36:04 UTC
Does this persist with rawhide kudzu? I can't reproduce this here.

Comment 4 Nathan Bryant 2003-02-22 22:54:14 UTC
looks like it works ok with kudzu-0.99.97-1


Note You need to log in before you can comment on or make changes to this bug.