Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80425 - (xkb) Meta key not working after choosing a French Canadian Keyboard
Summary: (xkb) Meta key not working after choosing a French Canadian Keyboard
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard: Waiting for bug to be reported upstre...
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-26 03:31 UTC by Marc Deslauriers
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-01 14:45:59 UTC


Attachments (Terms of Use)
my XF86Config file (deleted)
2003-01-23 12:42 UTC, Marc Deslauriers
no flags Details

Description Marc Deslauriers 2002-12-26 03:31:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
After installing Phoebe with a French Canadian keyboard, the right Alt "meta"
key does not work. As such, it is impossible to enter a bunch of different
characters, including "@".

Version-Release number of selected component (if applicable):
Phoebe 8.0.92

How reproducible:
Always

Steps to Reproduce:
1.Install Phoebe with a French Canadian Keyboard
2.Try and type a "@" by holding the right Alt key and pressing the "2" key.
3.
    

Actual Results:  Nothing happens.

Expected Results:  @

Additional info:

Comment 1 Mike A. Harris 2002-12-27 04:10:29 UTC
I believe this is a dupe of bug #79564 but could you check it and confirm
for me please?  Does the Windows key work as Meta?

I assumed this would be fixed upstream by now, but it seems it hasn't.
If it is still a problem, I'll try to whip up a patch.

Comment 2 Marc Deslauriers 2002-12-27 13:30:36 UTC
It looks like the same problem. Unfortunately, I can't confirm as I don't have a
Windows key on both my desktop computer and my Thinkpad.

Using the Windows key as Meta is not acceptable, even if I did have one on my
keyboard. It would be akin to moving the enter key to the left of the keyboard...

Comment 3 Marc Deslauriers 2003-01-23 00:46:16 UTC
This bug is still present in Phoebe 8.0.93.
I've tried a keyboard with a legacy windows key and that doesn't work as a Meta
key either.

There are a couple of other keys that don't work either, for example, the
e-acute "é" that is supposed to be on the slash key.

If you need any help trying to find a cure for this, or if you have packages to
test, I'd be glad to help.


Comment 4 Marc Deslauriers 2003-01-23 02:34:07 UTC
I am sorry, it's not the e-acute that doesn't work, but the c-cedilla "ç".


Comment 5 Mike A. Harris 2003-01-23 09:16:41 UTC
Please attach your XFree86 config file here using bugzilla's file
attachment feature below.

Please report this problem directly to devel@xfree86.org so the xkb
maintainers are aware of the problem, and can insure hopefully that it
is resolved before XFree86 4.3.0 is released.

Comment 6 Marc Deslauriers 2003-01-23 12:42:15 UTC
Created attachment 89548 [details]
my XF86Config file

Comment 7 Marc Deslauriers 2003-01-24 13:02:03 UTC
I have received a mail from Ivan Pascal <pascal@info.tsu.ru> with a fix for this
issue. I tried the fix, and it works. Here is the mail:

   Hello,

> I am trying RedHat's latest beta which includes XFree 4.2.99.3 and there
> is a bug in the xkb code. I cannot configure a proper French Canadian
> keyboard. When specifying "ca_enhanced" in the XF86Config file, some
> keys on the keyboard are not mapped properly.

  I should apologize I missed this layout in a new xkb rules file.
Thus what you got isn't a 'ca_enhanced' layout but a 'pre_XKB' keyboard map.

  The fix is very simple.
Find the rules file (/usr/X11R6/lib/X11/xkb/rules/xfree86 or
/etc/X11/xkb/rules/xfree86)
and add the layout name (ca_enhanced) to the end of string

! $oldlayouts = az bs ca fr_CH de_CH hu lt_std vn mn

-- 
 Ivan U. Pascal         |   e-mail: pascal@tsu.ru
   Administrator of     |   Tomsk State University
     University Network |       Tomsk, Russia

Comment 8 Mike A. Harris 2003-01-24 21:54:40 UTC
Added to 4.2.99.4-20030121.2 build.

Please test when available, and close ase RAWHIDE if it works properly,
or change to ASSIGNED if not.

Comment 9 Marc Deslauriers 2003-02-01 14:45:59 UTC
Tested 4.2.99.4-20030129.1. The problem is corrected.

Thank you very much Mike! IMO your work is under-appreciated. :)


Comment 10 Mike A. Harris 2003-02-01 18:35:17 UTC
Thanks for the feedback Marc.  Much appreciated.


Note You need to log in before you can comment on or make changes to this bug.