Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80418 - default terminal font is mis-reported as Sans
Summary: default terminal font is mis-reported as Sans
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libgnome
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-12-26 01:44 UTC by Alexandre Oliva
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-29 23:43:39 UTC


Attachments (Terms of Use)
Patch from SRPM (deleted)
2003-07-08 13:07 UTC, Anders Carlsson
no flags Details | Diff

Description Alexandre Oliva 2002-12-26 01:44:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
After switching from 96 to 126 DPI in Preferences -> Fonts -> Details, fonts got
larger in the display.  That was not what I wanted, so I switched them back, but
the fonts in gnome-terminal, window headers and desktop wouldn' t look like
originally any more.  In fact, inter-letter spacing was *very* inappropriate:
there was way too much of it.

Not even dfter restoring .gconf/, .gconfd/, .gnome/ and .gnome2/ from the backup
things got back to normal.  I had to remove .fonts.cache-1 to get back to what I
was used to.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
0.Take a backup copy of .gconf, .gconfd, .gnome and .gnome2
1.Starting off a (presumably) default font set up, choose Preferences -> Font ->
Details
2.Increase Resolution to say 126, and Close.
3.Terminal window grows.  Hate it :-)
4.Change some fonts to size 8 to get it back to a reasonable size.
5.Realize it only gets worse, so change them all back.
6.Change Resolution back to 96.
7.Terminal font looks very oddly-spaced.  Hate it more.  Pull some hair out.
8.Log out, restore the backup, and log back in
9.Note gnome-terminal still looks horrible
10.Log out again, restore backup again, then remove .fonts.cache-1
11.Log in once again

Actual Results:  gnome-terminal is now back to normal.  Phew!

Expected Results:  It should be back to normal after step 6.

Additional info:

Comment 1 Owen Taylor 2003-01-06 21:13:34 UTC
Can't reproduce the problem, and it doesn't really make sense to me.
.fonts.cache-1 has nothing to do with font rendering, it basically 
is just a list of fonts on the system.


Comment 2 Alexandre Oliva 2003-01-09 17:56:15 UTC
ok, so changing the DPI is not necessary at all to trigger the problem.  Just
changing font sizes to something else, then changing back, is enough to get
stuff to look horrible.

Comment 3 Owen Taylor 2003-01-09 18:09:44 UTC
The problem here is that a patch was removed from the libgnome SRPM
because it _should_ have been upstream. BUt it wasn't actually upstream
(libgnome-2.0.1-monospace.patch)

Comment 4 Havoc Pennington 2003-01-09 19:42:18 UTC
So let's file the bug upstream, or commit the patch upstream.
This is important for GNOME 2.2 also.

Comment 5 Havoc Pennington 2003-01-13 03:58:20 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103316

Removing MoveUpstream however to track for release.

Comment 6 Alexandre Oliva 2003-01-23 15:50:32 UTC
It still thinks the default font terminal is Sans in Phoebe2, even though from
the looks of the font it clearly isn't.  Until I actually change the font size.

Comment 7 Miloš Komarčević 2003-02-23 15:54:23 UTC
This is still a problem for me in Phoebe3.
The default terminal font is listed as Sans,
although it is actually Monospace.

The probelem with Monospace on sr_YU.UTF-8@cyrillic
locale is the already mentioned huge inter-character
spacing, so my terminal is wider than the screen.
Even now as I type this in Mozilla I see the same
problem with Monospace.

This has worked ok in Phoebe2, but the problem occurred
after upgrading to Phoebe3, and on another machine with
a clean install of Phoebe3 as well.

en_US locale seems to work without problems

Comment 8 Kjartan Maraas 2003-05-12 12:56:33 UTC
I don't see the patch upstream. Add it please?

Comment 9 Anders Carlsson 2003-07-08 13:07:27 UTC
Created attachment 92795 [details]
Patch from SRPM

This is the patch from the SRPM. I've applied it to libgnome HEAD and closed
the b.g.o bug

Comment 10 Kjartan Maraas 2004-03-29 19:08:30 UTC
Guess this could be closed as well then?


Note You need to log in before you can comment on or make changes to this bug.