Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80404 - No apm in phoebe kernel
Summary: No apm in phoebe kernel
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-25 22:44 UTC by Tom "spot" Callaway
Modified: 2013-07-03 02:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:34 UTC


Attachments (Terms of Use)

Description Tom "spot" Callaway 2002-12-25 22:44:19 UTC
Description of problem:

No APM in Phoebe kernel. This is a severe problem on hardware without ACPI (or
working ACPI implementations). Example: My Dell Inspiron 4000, which uses APM. I
now have 0 power management.

Enabling ACPI is good, but not at the cost of APM.

Version-Release number of selected component (if applicable):

2.4.20-2.2

How reproducible:

Always.

Steps to Reproduce:
1. Boot.
2. Notice that I have no power management.
    
Actual results:

No power management.

Expected results:

Power management.

Additional info:

Is there a reason that APM was stripped?

Comment 1 Tom "spot" Callaway 2002-12-25 22:59:19 UTC
Addendum: ACPI doesn't seem to work on this machine either, there is no
/proc/acpi structure created. I can attach dmidecode and acpidmp if needed.

Comment 2 louisgtwo 2002-12-25 23:17:45 UTC
the ACPI modules do not load automatically. You can recompile the kernel with
acpi in, or modprobe the modules which should be done in the initscripts. Even
then ACPI has limited power saving features until kernel-2.5/2.6 shows up with
the new driver model.

Comment 3 Warren Togami 2002-12-26 07:02:35 UTC
Well, the kernel does have APM.  When I type "dmesg" these two lines are within.
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
apm: overridden by ACPI.

My computer does support ACPI though.  Perhaps there is some bug where APM
doesn't engage with ACPI isn't available.

Comment 4 Bill Nottingham 2002-12-31 05:33:36 UTC
ACPI is enabled by default. You can boot with acpi=off.

Comment 5 John Coonrod 2003-01-12 03:14:02 UTC
This is very odd. When I look at the "services" it shows apmd ticked. But if I
enter "apm" from the terminal, it says "No APM support in kernel" - so what's
the deal? For laptops (mine is ibm x21) what's the good of having a linux that
doesn't support apm?

Comment 6 Jeff Garzik 2003-01-17 21:16:41 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.