Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80386 - mouse click on mc running in gnome-terminal causes freeze-up
Summary: mouse click on mc running in gnome-terminal causes freeze-up
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: vte
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 80831 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-25 16:54 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 03:47:23 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-25 16:54:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If I run mc in a gnome terminal and mouse-click within the terminal window (but
not on the window borders, menu bar, etc), then the terminal "freezes" --
doesn't respond to keyboard input.

Using the "terminal" -> "reset and clear" entry from the menu bar will
"unfreeze" the terminal.  Openning a new term window and killing the mc process
does not "unfreeze" the terminal.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a new gnome-terminal
2. Run mc
3.
    

Actual Results:  Term stops responding to keyboard input

Expected Results:  Should be able to click within a gnome-terminal running mc
and not experience a "freeze-up".

Additional info:

Comment 1 Bill Nottingham 2002-12-31 05:17:31 UTC
Also happens with aumix. Probably libgpm related.

Comment 2 Bill Nottingham 2003-01-14 03:47:23 UTC
Fixed in 0.10.9-1.

Comment 3 Nalin Dahyabhai 2003-01-14 04:28:08 UTC
*** Bug 80831 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.