Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80380 - NFS not working due to portmap not being started
Summary: NFS not working due to portmap not being started
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-25 13:56 UTC by Manfred Hollstein
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-08 21:48:05 UTC


Attachments (Terms of Use)

Description Manfred Hollstein 2002-12-25 13:56:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

Description of problem:
Choosing "y" at the question whether to activate NFS or not doesn't
start the required services, rendering NFS non-functional when using
the "System Administrator Tools for Red Hat Linux 8.0" CD.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from 8.0's sysadmin CD
2.Choose "y" when asked for NFS
3.mount an NFS filesystem from a remote server
    

Actual Results:  No prompt will be shown again after issueing the "mount"
command. Filesystem is not mounted.

Expected Results:  Remote filesystem should be mounted and accessible, prompt
should be seen almost immediately after issueing the "mount" command.

Additional info:

The "portmap" service is *not* actually started. This is caused
by the following line in /etc/init.d/portmap:

[ -w /etc/passwd ] || exit 0

Since "/" is mounted read-only, this test obviously fails and portmap
will not be started.

There is no actual user control (you're not required to login in,
aren't you ;-) ), so the above line doesn't really make any sense
for the sysadmin CD and should be removed.

Comment 1 Michael Fulbright 2003-01-08 21:48:05 UTC
This should work now.


Note You need to log in before you can comment on or make changes to this bug.