Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80373 - Print-Scrn button no longer runs gnome-panel-screenshot
Summary: Print-Scrn button no longer runs gnome-panel-screenshot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: phoebe
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
: 80097 80510 83053 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-25 08:31 UTC by Warren Togami
Modified: 2007-04-18 16:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 20:49:10 UTC


Attachments (Terms of Use)

Description Warren Togami 2002-12-25 08:31:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Phoebe no longer runs gnome-panel-screenshot when you hit the Print-Screen
button like it worked in Red Hat 8.0.


The following info may or may not be related to this problem, but it does
describe some strange behavior of the gnome-keybinding-properties tool that
should be fixed later.  Havoc mentioned testing the "Keyboard Shortcuts" in the
"Preferences" menu because this may be some keymapping issue.  The default
settings there are:

Take a screen shot: Print
Take a screen shot of window: <Alt>Print

If you change the first option to most other keys it works fine.  If you 
attempt to set it to "Print" when it is already "Print", it displays a confusing
error message, "That accelerator key is already in use by:
/apps/panel/global/screenshot_key"  If you change the second option there is no
way to change it back to <Alt>Print, instead becomes <Alt>SysRq.

Version-Release number of selected component (if applicable):
Phoebe

How reproducible:
Always

Steps to Reproduce:
1. Hit Print Screen button  

Actual Results:  
Nothing happens.

Expected Results:  
It should run gnome-panel-screenshot.

Comment 1 Marius Andreiana 2002-12-29 12:39:30 UTC
*** Bug 80510 has been marked as a duplicate of this bug. ***

Comment 2 Havoc Pennington 2003-01-03 03:12:02 UTC
*** Bug 80097 has been marked as a duplicate of this bug. ***

Comment 3 Kang Jeong-Hee 2003-01-03 15:34:04 UTC
$ xmodmap -pke | grep Print
keycode  92 = Print Sys_Req
keycode 111 = Print Sys_Req

why twice?

Comment 4 Tommy McNeely 2003-01-05 06:49:34 UTC
Instead of filing a bug, I will just latch onto this one :)

Comment 5 Larry Troan 2003-01-09 15:45:39 UTC
Am told fix is in gingin Beta4.

Comment 6 Havoc Pennington 2003-01-09 17:26:54 UTC
What was the fix? I didn't fix it... can I close the bug?

Comment 7 petrosyan 2003-01-21 04:47:02 UTC
Prnt Scrn and <Alt>-PrntScrn still don't work in Red Hat 8.0.93 (Phoebe2).


Comment 8 Havoc Pennington 2003-01-29 21:09:42 UTC
*** Bug 83053 has been marked as a duplicate of this bug. ***

Comment 9 Gene Czarcinski 2003-01-29 22:18:30 UTC
On my 8.0.93 system, only keycode 111 shows up (same as on 8.0) but it still
does not work.

Comment 10 Havoc Pennington 2003-01-31 22:47:15 UTC
Conclusion of analysis here is that part of Owen's X patch was lost. The 
following needs to be deleted from all keymaps:

    key <SYRQ> {
        type= "PC_SYSRQ",
        symbols[Group1]= [           Print,         Sys_Req ]
    };



Comment 11 Mike A. Harris 2003-02-10 13:11:55 UTC
Should be fixed in XFree86-4.2.99.901-20030209.0 in rawhide.  Please
test and close RAWHIDE if it works, or ASSIGNED if not.

Changing bug to MODIFIED state.

Comment 12 Kjartan Maraas 2003-02-10 14:31:53 UTC
Still not fixed here. I have two entries for Print Sys_Req. This keyoard also
has pgup/pause, pgdn/break, home/scroll, end/numlk, insert/prtsc, and
delete/sysrq. Is this the normal grouping for these keys for everyone?

I'm using XFree86-4.2.99.901-20030206.0

Comment 13 Jay Turner 2003-02-11 13:06:32 UTC
Bouncing this back to Assigned, as there still appear to be some issues.

Comment 14 Gene Czarcinski 2003-02-11 16:06:57 UTC
Seems to work OK for me - XFree86 4.2.99.901-20030209.1 from rawhide.


Note You need to log in before you can comment on or make changes to this bug.