Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80372 - mknod doesn't work because PYTHONPATH isn't set
Summary: mknod doesn't work because PYTHONPATH isn't set
Keywords:
Status: CLOSED DUPLICATE of bug 80778
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-25 05:58 UTC by Nathan G. Grennan
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:34 UTC


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-12-25 05:58:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
mknod doesn't work in the shell during the installer or during rescue mode
because PYTHONPATH isn't being set. So when mknod looks for the isys module
which is in /usr/lib/anaconda it isn't found.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot disc1 cd
2. Type linux rescue at the boot: prompt
3. Skip mount
4. mknod /tmp/hde1 b 33 1
    

Actual Results:  Traceback about inability to import the module isys

Expected Results:  It to make /tmp/hde1

Additional info:

Comment 1 Nathan G. Grennan 2002-12-25 06:26:53 UTC
isys is actually in /mny/runtime/usr/lib/anaconda

I tried  export PYTHONPATH=/mnt/runtime/usr/lib/anaconda  in the shell during
the install and it made mknod work.

Comment 2 Jeremy Katz 2002-12-26 03:55:05 UTC
Noticed this when I was testing something before I left for the holidays, so
it's already fixed in CVS

Comment 3 Mike McLean 2003-01-02 23:02:29 UTC

*** This bug has been marked as a duplicate of 80778 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.