Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80364 - kdm stops operating for good - gdm malfunctioning too
Summary: kdm stops operating for good - gdm malfunctioning too
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 7.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-25 01:23 UTC by Michal Szabelski
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-10 23:53:43 UTC


Attachments (Terms of Use)

Description Michal Szabelski 2002-12-25 01:23:21 UTC
Description of problem:
kdm stopped operating. One day only the text console appeared.
I tried starting kdm manually - it just stopped with no action.
I tried to strace it, gdb it, nothing. It just stops.

Version-Release number of selected component (if applicable):

don't know how to check. Standard kdm with RedHat 7.2

How reproducible:
Maybe you should press reset button (I think I did it)


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
my gdm I switched to is malfunctioning too - when I log out sometimes
the text console appears. gdm _is_ still running (ps -elf).
I cannot kill it - when I try to, it only respawns, so that there is
one more gdm process - strange, isn't it?
I looked at bug #22213 - it is not the same

Comment 1 Michal Szabelski 2002-12-25 01:25:44 UTC
I forgot to mention - my kde is version 2.2-10

Comment 2 Michal Szabelski 2002-12-31 15:10:37 UTC
In case anybody gets interested after Xmas and New Year...
I worked on it. Here's what I found:

At the time being starting eth0 is what is causing the malfunction.
However, I'm not sure that this is the main issue, because kdm stopped working
_before_ we had network connection (we got it in December) and _before_ we
bought our ethernet card.

The card: this is PCI 10/100 LG Rhinefet (on a VIA chipset) that comes with a
driver,
which I compiled and installed into kernels (it's rhinefet.o module).

Now, I have two kernels: 2.4.7-10 and 2.4.7-10custom1. The first one is 
standart. The second one is enterprise (not that it gives me anything), slightly
modified - tap device support is turned on,getrusage returns some more data
and a few others. Because I usually use the custom version, I thought maybe I
messed sth up - no, it's all the same with the standart kernel (I rebuilt 
rhinefet.o for it - there is no interaction between two kernels, they have 
separate module directories, source trees, etc.)

I usually start network manually - I have a script that set's up ipchains,
lo, eth0, Sun Chilisoft ASP, and a few other minor things. I thought this might
be the problem - so I turned on "network" in serviconf and rebooted - I got 
just the text console with gdm running, but no display. When I started xdm
manually, it actually worked. I may turn to use xdm, but what if it fails too?

I repeat - this is just a symptom, not the main issue. kdm stopped operating
_before_ I had bought this ethernet card.

One more thing:
up2date says it cannot update kdebase package (reason: config modified).
What does that mean? What config? I customized my desktop: I have my own colors,
8 virtual desktops, modified what's on my panel, changed icon sizes, etc.
Is that what up2date calls 'config'?

Another:
I use KDE, my dad uses Fvmw2.
When I start the network, everything is OK until I log off (then I get the text
console).
When my dad starts network, from this point he cannot open any new window.

Another (maybe unrelated, but I don't understand it either):
When my dad opens xterm in his Fvmw2, echo $PATH shows paths which are included
_only_ in /root/.bashrc. Now, the whole /root directory has mode 0750 (root 
root), which means my dad (js users) has no access whatsoever to that directory.
Also /etc/bashrc is sourced twice.
When my dad logs in in any other way (su -l js, or from the text console),
the paths are OK, ie. just as I would expect them to be.(/root/.bashrc in not
sourced)

Maybe you'll find this useful:

KDE 2.2-10

Xserver:
version 11.0 by XFree86
display: 0.0
Some other version number: 40100000
Screens: one screen, screen 0
1280x1024 pixels (332 x 250 mm)
98 X 104 dpi
Depths: 24,1,4,8,15,16,32
ID 0x32
Depth: 24-bit



uname -a
Linux 251-19.lodz.mm.pl 2.4.7-10custom1 #88 sob lis 23 23:22:47 CET 2002 i686
unknown

more /proc/interrupts
           CPU0
  0:     230305          XT-PIC  timer
  1:       9046          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
  9:      12125          XT-PIC  Intel ICH2
 11:      10406          XT-PIC  usb-uhci, usb-uhci, eth0
 12:      21375          XT-PIC  PS/2 Mouse
 14:      74031          XT-PIC  ide0
 15:      65518          XT-PIC  ide1
NMI:          0
LOC:          0
ERR:          0
MIS:          0


more /proc/iomem
00000000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000f0000-000fffff : System ROM
00100000-0ffeffff : System RAM
  00100000-00239827 : Kernel code
  00239828-0024ac5b : Kernel data
0fff0000-0fff2fff : ACPI Non-volatile Storage
0fff3000-0fffffff : ACPI Tables
d0000000-d7ffffff : PCI Bus #01
  d0000000-d7ffffff : nVidia Corporation NV11 DDR
d8000000-dbffffff : PCI device 8086:1130 (Intel Corporation)
dc000000-ddffffff : PCI Bus #01
  dc000000-dcffffff : nVidia Corporation NV11 DDR
de000000-de0fffff : PCI Bus #02
  de000000-de0000ff : PCI device 1106:3106 (VIA Technologies, Inc.)
ffb00000-ffffffff : reserved


more /proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0cf8-0cff : PCI conf1
5000-500f : Intel Corporation 82801BA(M) SMBus
c000-cfff : PCI Bus #02
  c000-c0ff : PCI device 1106:3106 (VIA Technologies, Inc.)
    c000-c0ff : rhinefet
d000-d01f : Intel Corporation 82801BA(M) USB (Hub A)
  d000-d01f : usb-uhci
d400-d41f : Intel Corporation 82801BA(M) USB (Hub B)
  d400-d41f : usb-uhci
d800-d8ff : Intel Corporation 82801BA(M) AC'97 Audio
  d800-d8ff : Intel ICH2
dc00-dc3f : Intel Corporation 82801BA(M) AC'97 Audio
  dc00-dc3f : Intel ICH2
f000-f00f : Intel Corporation 82801BA IDE U100
  f000-f007 : ide0
  f008-f00f : ide1

Graphics Card:
NVidia GeForce 2 MX 200 NV11 DDR

Monitor:
LG Flatron 795FT

CPU:
Celeron (Coppermine) 850MHz
Stepping: 10
Cache size: 128 KB

Memory:
256 MB SDRAM

40 GB HardDrive (IDE I think) - primary master (Geom: 77545/16/63) (Model: 
    ST348010A)
SONY CR-DOM 52x - secondary master CDU-5221
Lite-On CR-RW 48/16/48 - secondary slave LTR-45125S
82801 BA/BAM ICH2 AC'97 Audio Controller (on-motherboard one) Intel
82815 815 Chipset Host Bridge and Memory Controller Hub Intel
82820 820 (Camino 2) Chipset ISA Bridge (ICH2) Intel
Two USB UHCI Root Hubs (82820 Camino 2 Chipset USB Hubs A and B) Intel
3.5 1.44 MB floppy (some generic)
No USB devices
No PCMCIA devices
PS/2 3 Button + roller Mouse
keyboard

239 MB swap partition
I add another 1GB of swap space with swapon (I tried not to do that in case it 
is causing problems, but no)



The system is dual-booted with Windows XP

Comment 3 Ngo Than 2003-11-10 23:53:43 UTC
please update to current release, which should fix this problem


Note You need to log in before you can comment on or make changes to this bug.