Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80363 - Package manager doesn't recognize packages to upgrade
Summary: Package manager doesn't recognize packages to upgrade
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-25 00:44 UTC by Stephen Drye
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-31 07:42:45 UTC


Attachments (Terms of Use)

Description Stephen Drye 2002-12-25 00:44:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
When starting the redhat-package-manager from an existing Psyche install (since
anaconda is broken with Promise RAID controllers, argh) the package manager
doesn't notice that installed packages need upgraded.  So there's no way using
this tool to install the new packages from Phoebe.

It also doesn't check to see if a needed parent package is part of the install
(ie, php-mysql complains that php is needed, when php is also chosen).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into Psyche.
2. Put CD #1 in and allow the autorun

    

Actual Results:  The package manager refused to install any packages

Expected Results:  The package manager should have installed any packages that
were new versions.

Additional info:

Comment 1 Jeremy Katz 2002-12-31 07:42:45 UTC
This isn't something which redhat-config-packages is intended to support at the
current time.


Note You need to log in before you can comment on or make changes to this bug.