Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80355 - TB rhpl/executil.py:216:gtkExecWithCaptureStatus: TypeError: len() of unsized object
Summary: TB rhpl/executil.py:216:gtkExecWithCaptureStatus: TypeError: len() of unsized...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhpl
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 80869 81537 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-24 22:23 UTC by Warren Togami
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-24 11:40:18 UTC


Attachments (Terms of Use)
NCDevModem.py and executil.py changes (deleted)
2003-01-02 17:49 UTC, Paul Coleman
no flags Details

Description Warren Togami 2002-12-24 22:23:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
https://listman.redhat.com/pipermail/phoebe-list/2002-December/000041.html
Read the entire story here

After a text mode install from ISO's on another partition, I have no network
devices configured.  Within redhat-config-network I added my 8139too ethernet
device.  After I clicked "Activate" then "Yes", redhat-config-network crashes
after the "Network device activating..."

window pops Component: redhat-config-network
Version: 1.1.86
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/executil.py:216:gtkExecWithCaptureStatus: 

TypeError: len() of unsized object

Traceback (most recent call last):
    File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 734, in on_deviceActivateButton_clicked
      (status, txt) = intf.activate(device)
    File
"/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
107, in activate
      return gtkExecWithCaptureStatus(command, [command, device])
    File "/usr/lib/python2.2/site-packages/rhpl/executil.py", line 216,
in gtkExecWithCaptureStatus
      if len(catchfd):
TypeError: len() of unsized object

Local variables in innermost frame:
gtk: <module 'gtk' from
'/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
catchfd: 1
searchPath: 0
read: 13
stdin: 0
argv: ['/sbin/ifup', 'eth0']
write: 14
command: /sbin/ifup
closefd: -1
root: /
childpid: 0
up.  Traceback:

I can also reproduce this every time after removing the device and re-adding.

Version-Release number of selected component (if applicable):
Phoebe redhat-config-network-1.1.86-1

How reproducible:
Always

Steps to Reproduce:
1. Start with no devices in redhat-config-network
2. Add 8139too device
3. Click activate

Comment 1 Paul Jenner 2002-12-30 11:52:30 UTC
Confirmed the same crash activating an interface in bug #80712.

Comment 2 Paul Coleman 2003-01-02 17:49:15 UTC
Created attachment 89061 [details]
NCDevModem.py and executil.py changes

Comment 3 Harald Hoyer 2003-01-08 16:44:54 UTC
should be fixed in rhpl > 0.72

Comment 4 Harald Hoyer 2003-01-08 17:00:31 UTC
*** Bug 80869 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2003-01-13 11:05:43 UTC
*** Bug 81537 has been marked as a duplicate of this bug. ***

Comment 6 Jay Turner 2003-01-21 15:35:50 UTC
Warren, can you confirm this issue has been resolved?

Comment 7 Warren Togami 2003-02-24 10:01:17 UTC
Confirmed with:
redhat-config-network-1.1.97-1
rhpl-0.92-1



Note You need to log in before you can comment on or make changes to this bug.