Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80351 - sis900 eth0 module reports "failed: no link present. Check cable?"
Summary: sis900 eth0 module reports "failed: no link present. Check cable?"
Keywords:
Status: CLOSED DUPLICATE of bug 80322
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 21:47 UTC by Scott Dowdle
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:33 UTC


Attachments (Terms of Use)

Description Scott Dowdle 2002-12-24 21:47:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212

Description of problem:
onboard SiS900 ethernet no longer works.  It worked in 7.x and 8.0.  Not sure
what the problem is.  The /etc/modules.conf has it in there:

"alias eth0 sis900" and the module is loaded:

Module      Size   Used by   Not tainted
sis900     16492   0

At boot time get an error message about "failed: no link present.  Check
cable?"... and yes, I've checked the cable... works fine on reboot into Windows
and worked fine on previous RHL installs.

The phoebe install was a fresh install (did NOT upgrade) and I haven't done any
messing around to break it (nor to fix it).

/proc/pci says:

Bus 0, device 1, function1:
  Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet
(rev 130)
    IRQ 12.
    Master Capable.  Latency=64.  Min Gnt=52. Max Lat=11
    I/O at 0xcc00 [0xccff].
    Non-prefetchable 32 bit memory at 0xcfffb000 [0xcfffbfff].

/proc/pci also shows a SiS 56k Winmodem (Smart Link HAMR5600 compatible) (rev1
60) also on IRQ 12.

Repeated attempts to "service network restart" result in same error (failed: no
link present. Check cable?").

Not sure where to go from here.  Suggestions?!?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try Booting System
2. Seems to initialize device but can't obtain an address
3. Worked fine in previous RHL versions
    

Additional info:

Comment 1 Bill Nottingham 2002-12-24 21:59:30 UTC

*** This bug has been marked as a duplicate of 80322 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:33 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.