Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80339 - command line up2date crashes
Summary: command line up2date crashes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 18:47 UTC by John Hawley, Jr.
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-21 17:33:29 UTC


Attachments (Terms of Use)

Description John Hawley, Jr. 2002-12-24 18:47:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
When running up2date from the command line, the utility bombs each time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date -l
2.
3.
    

Actual Results:  [root@eagle /rhnpackages]# up2date -l
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: libbz2.so.1: cannot open shared object file: No such file or 
directory

Expected Results:  should have connected to RHN to retreive updates.  

Additional info:

[root@eagle /rhnpackages]# rpm -q up2date
up2date-2.8.39-1.6.2
[root@eagle /rhnpackages]# rpm -q rpm rpm-python
rpm-4.0.2-6x
rpm-python-4.0.2-8
[root@eagle /rhnpackages]# rpm -q bzip2
bzip2-0.9.5d-2

Comment 1 Mike McLean 2003-01-03 23:29:30 UTC
You seem to have the wrong version of rpm-python installed.  Get the errata
rpm-python:

ftp://updates.redhat.com/6.2/en/os/i386/rpm-python-4.0.2-6x.i386.rpm

while you're at it make sure you have the latest errata versions of:
db3 rhn_register python python-popt python-xmlrpc rpm-python openssl

Try that and let us know if it solves your problem.


Comment 2 Mike McLean 2003-07-21 17:33:29 UTC
Closing due to lack of activity.


Note You need to log in before you can comment on or make changes to this bug.