Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80323 - RFE: Please re-add manual fdisk support
Summary: RFE: Please re-add manual fdisk support
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 13:24 UTC by Bernd Bartmann
Modified: 2007-04-18 16:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-24 19:12:41 UTC


Attachments (Terms of Use)

Description Bernd Bartmann 2002-12-24 13:24:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Why was manual fdisk support removed? Please re-add this option!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to manually use fdisk in anaconda.
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2002-12-24 19:12:41 UTC
fdisk is not at all a very user-friendly application and people get into it not
knowing what they're doing.  Users who know how to use fdisk are also capable of
switching vts and doing their partitioning with fdisk that way.

Comment 2 Warren Togami 2002-12-24 20:52:28 UTC
Could it be in only "expert" mode but not standard install?


Comment 3 Nathan G. Grennan 2002-12-25 02:11:50 UTC
I think it was a poor choice to remove, especially completely. Currently because
of another bug with keyboard input I can't even change vts.

Comment 4 James Ralston 2003-01-28 00:49:25 UTC
I can see how keeping inexperienced users away from fdisk would be a Good Thing.

But I agree with Warren, in that I think it would be reasonable to have fdisk
appear as an option in expert mode.  (Heck, the splash screen doesn't even
mention expert mode anymore, so there shouldn't be any reasonable way for
novices to get into expert mode in the first place.)

If Red Hat is adamant that fdisk will not be shown as an option in the installer
(even in expert mode), then please make sure the final release notes mention
*why* fdisk was removed.  Otherwise, expert users (the ones who know to switch
VTs and run it by hand) won't know whether it was removed to keep it away from
inexperienced users, or whether it was removed because it's buggy and shouldn't
be used.

(I didn't use fdisk during my install, precisely because I didn't know *why* it
had been removed as an option in the installer.)



Note You need to log in before you can comment on or make changes to this bug.