Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80313 - start order between network and PCMCIA
Summary: start order between network and PCMCIA
Keywords:
Status: CLOSED DUPLICATE of bug 51322
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SysVinit
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 10:51 UTC by Raphael Jacquot
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:32 UTC


Attachments (Terms of Use)

Description Raphael Jacquot 2002-12-24 10:51:01 UTC
Description of problem:
The PCMCIA subsystem is started after the Network subsystem. This is non
practical if the only network card in the system is a pcmcia adapter.
Starting the two subsystems in that order poses a number of problems such as
delaying network interface initialization (which is a minor delay) to blocking
the machine several dozens of seconds (minutes ?) when using PPPOE to connect
for instance to a DSL provider, as the PPP process is trying to hook onto the
ethernet adapter which hasn't been started yet.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
0. use a pcmcia network adapter
1. set up a DSL provider
2. boot the machine
3. hang when trying to launch PPPOE while the ethernet adapter is not even loaded
    
Actual results:
hangs the boot process for a while until if finally times out, not finding a
connection

Expected results:
should start the pcmcia so that the adapter is loaded, then start the network,
and all would be well

Additional info:

Comment 1 Bill Nottingham 2002-12-24 21:12:20 UTC

*** This bug has been marked as a duplicate of 51322 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.