Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80308 - can not choose vmware display adapter during setup
Summary: can not choose vmware display adapter during setup
Keywords:
Status: CLOSED DUPLICATE of bug 70153
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-24 10:24 UTC by Jeroen Janssen
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:32 UTC


Attachments (Terms of Use)

Description Jeroen Janssen 2002-12-24 10:24:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021217

Description of problem:
During installation all sorts of display adapters are displayed in a list. 

The vmware display driver is not present in this list, making it impossible to
correctly configure X during setup (running in vmware).

Please add the vmware display driver to the list of supported display drivers so
we can choose it during installation.

Also, if possible please add auto-detection for this adapter.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot installation from CD (within VMware)
2. continue to X configuration
3. look at driver list
    

Actual Results:  vmware display is not present in the list

Expected Results:  vmware display to be present in the list

Additional info:

Comment 1 Warren Togami 2002-12-24 10:31:43 UTC
What are the PCI ID's of the VMWare display device?
You should be able to find it using lspci -v and lspci -n.


Comment 2 Jeroen Janssen 2002-12-24 10:47:07 UTC
I think this is it:

00:0f.0 Class 0300: 15ad:0405

00:0f.0 VGA compatible controller: VMWare Inc: Unknown device 0405 (prog-if 00
[VGA])
	Flags: medium devsel
	I/O ports at 10c0 [size=16]
	Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
	Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
	Expansion ROM at <unassigned> [disabled] [size=32K]

Is this enough information?

Comment 3 Mike A. Harris 2002-12-27 01:58:33 UTC
Reassigning to XFree86 component.

Comment 4 Mike A. Harris 2002-12-27 01:59:56 UTC

*** This bug has been marked as a duplicate of 70153 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.