Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80300 - SRPMS: install failed due to files
Summary: SRPMS: install failed due to files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nvi-m17n
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-24 09:21 UTC by Sysoltsev Slawa
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-25 07:31:00 UTC


Attachments (Terms of Use)

Description Sysoltsev Slawa 2002-12-24 09:21:05 UTC
Description of problem:
Trying to build & install nvi-m17m from SRPMS I've got such errors:

Executing(%doc): /bin/sh -
e /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/rpm-tmp.37990
+ umask 022
+ cd /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/BUILD
+ cd nvi-1.79
+ DOCDIR=/netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/nvi-m17n-1.79
+ export DOCDIR
+ rm -rf /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/nvi-m17n-1.79
+ /bin/mkdir -p /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-
1.79-buildroot/usr/share/doc/nvi-m17n-1.79
+ cp -pr FAQ LAYOUT LICENSE README 
docs /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/n
vi-m17n-1.79
+ cp -pr -P build/README build/README.LynxOS catalog/README cl/README.signal 
db/README /netbatch/TC11690/rh80_ia32_J/default/WORK_
DIR/tmp/nvi-m17n-1.79-buildroot/usr/share/doc/nvi-m17n-1.79
cp: cannot create regular file 
`/netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/nvi-m17n-
1.79/README': Permission denied
cp: cannot create regular file 
`/netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/nvi-m17n-
1.79/README': Permission denied
cp: cannot create regular file 
`/netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/nvi-m17n-1.79-
buildroot/usr/share/doc/nvi-m17n-
1.79/README': Permission denied
error: Bad exit status 
from /netbatch/TC11690/rh80_ia32_J/default/WORK_DIR/tmp/rpm-tmp.37990 (%doc)

As I suppose problem in .spec file in line:
%doc -P build/README* catalog/README cl/README.signal db/README

rpm, I have installed on my system, copies all these README files in one doc 
directory, overwriting them. I don't sure your rpm does same way but you should 
understand that with rpm manager installed by default all except last README 
files will be overwritten, so this action to enumerate many README files is 
just useless. Moreover, as all these README files have '-w' attribute in 
package (owner can't write) (why ? For sources, it is very annoyable when you 
couldn't write source you were just editing) so `cp` emits error trying to 
overwrite these files. As a result installation failed.

You should fix your %doc files to have different names.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. rpm -bb nvi-m17n.spec

    
Actual results:
Installation error, missed documentation.

Expected results:
Succesfully built & correctly(succesfully & without loss of information) 
installed package.

Additional info:

Comment 1 Akira TAGOH 2003-04-25 07:31:00 UTC
I'm closing this now, because it was already fixed in the current release.


Note You need to log in before you can comment on or make changes to this bug.