Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80278 - (Savage MX/IX) XFree starts with nothing displayed.
Summary: (Savage MX/IX) XFree starts with nothing displayed.
Keywords:
Status: CLOSED DUPLICATE of bug 80346
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79578 82788
TreeView+ depends on / blocked
 
Reported: 2002-12-23 22:06 UTC by Pete Toscano
Modified: 2008-01-17 17:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:31 UTC


Attachments (Terms of Use)
XF86Config (deleted)
2002-12-27 18:16 UTC, Pete Toscano
no flags Details
XF86 Log file with swcursor (deleted)
2002-12-27 18:17 UTC, Pete Toscano
no flags Details
XF86 log with hwcursor (deleted)
2002-12-27 18:18 UTC, Pete Toscano
no flags Details
T23 - XF86Config (deleted)
2003-01-01 17:45 UTC, Nitin Dahyabhai
no flags Details
T23 - XFree86 log file with HWCursor on (deleted)
2003-01-01 17:46 UTC, Nitin Dahyabhai
no flags Details
T23 - XFree86 log file with SWCursor on (deleted)
2003-01-01 17:46 UTC, Nitin Dahyabhai
no flags Details

Description Pete Toscano 2002-12-23 22:06:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021128

Description of problem:
When I start X (startx) on my laptop (IBM Thinkpad T22), the screen goes blank
and stays that way until I hit Ctrl-Alt-Backspace.  I can still switch between
virtual consoles as if X were running.  The driver used is "savage" and the
boardname is "S3 Savage/MX", just like it is in Psyche.  I tried the XF86Config
file from Psyche, but the results were the same.  

FWIW, I could only do a text install of Phoebe.  The standard install just has a
bunch of "junk" on the screen.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.startx
2.
3.
    

Actual Results:  Blank screen.  

Expected Results:  Graphics

Additional info:

Ctrl-Alt-BS drops back to the console.

Comment 1 Nitin Dahyabhai 2002-12-24 06:33:58 UTC
The same thing happens on a T23 during the install process,
identified by S3's id program as "SuperSavage/IXC SDR (584)".

(++) Log file: "/dev/null", Time: Tue Dec 24 01:13:43 2002
(++) Using config file: "/tmp/XF86Config.test"
(EE) Failed to load module "glx" (modules does not exist, 0)
(EE) SAVAGE(0): Failed to fetch any BIOS modes.  Disabling BIOS.
error opening security policy file /etc/X11/xserver/SecutiryPolicy
Could not init font path element unix/:7100, removing from list!
cat: //.Xauthority: No such file or directory


Comment 2 Panu Matilainen 2002-12-24 10:24:16 UTC
On T21 (Savage MX I think) X does start but has really bad distortions in the
picture (mouse movements cause all sorts of random flickering around the screen)
with same exact configuration where RH8.0 worked flawlessly. Dropping bpp from
24 to 16 seems to fix it however.

Comment 3 Mike A. Harris 2002-12-27 06:02:37 UTC
Hmm, it's possible I suppose that the new Xcursor code has messed up the
Savage driver somehow.  I don't have Savage hardware personally though to
investigate.  Could each of you please attach your X server config file
and log file as separate individual uncompressed file attachments to the
bug report?  I will contact the Savage driver maintainer and pass along
to him the information you provide.  Hopefully it's nothing major.

Also, could each of you try using the option "swcursor" in your config file,
and if that does not work, please try using "hwcursor".  These options
go in the Device section of the config file as documented in the XF86Config
manpage.

Thanks in advance.

Comment 4 Pete Toscano 2002-12-27 18:16:50 UTC
Created attachment 88949 [details]
XF86Config 

This is with hwcursor turned on. Everything else is the same.

Comment 5 Pete Toscano 2002-12-27 18:17:46 UTC
Created attachment 88950 [details]
XF86 Log file with swcursor

Log file with swcursor enabled.

Comment 6 Pete Toscano 2002-12-27 18:18:29 UTC
Created attachment 88951 [details]
XF86 log with hwcursor

Log file with hwcursor enabled.

Comment 7 Nitin Dahyabhai 2003-01-01 17:45:36 UTC
Created attachment 89037 [details]
T23 - XF86Config

Comment 8 Nitin Dahyabhai 2003-01-01 17:46:19 UTC
Created attachment 89038 [details]
T23 - XFree86 log file with HWCursor on

Comment 9 Nitin Dahyabhai 2003-01-01 17:46:46 UTC
Created attachment 89039 [details]
T23 - XFree86 log file with SWCursor on

Comment 10 Nitin Dahyabhai 2003-01-03 22:27:58 UTC
First seen in XFree86-4.2.99.2-0.20021126.8 and still broken in
XFree86-4.2.99.3-20021230.0.

Comment 11 Panu Matilainen 2003-01-09 11:07:05 UTC
Hmm, something funny with T21: it *did* work the first time I tried but not
after that (X starts up but with blank / screwed up screen). Adding "noaccel"
option "fixes" it. Additionally with "hwcursor" or without it the mouse cursor
does show but it also shows the original X shaped cursor in the middle of the
screen (which however vanishes by itself sooner or later, haven't been able to
figure out when/why). Adding "swcursor" option fixes the cursor issue. This on
all XFree86 versions from the phoebe-version up to XFree86-4.2.99.3-20021230.3
from rawhide.

Comment 12 Pete Toscano 2003-01-28 15:00:09 UTC
Tryed Phoebe 2 (8.0.93) and the X-based install works (though there's a lot of
flicker), but I still cannot start X after logging in.  Just sits at a blank
screen until I hit CTRL-ALT-BACKSPACE.

Comment 13 Mike A. Harris 2003-01-31 13:42:54 UTC
I'm currently awaiting the release of the savage driver 1.1.27t
source code from Tim Roberts for this issue.  hopefully it won't be
long now.

Comment 14 Mike Chambers 2003-02-11 03:24:43 UTC
Mike,

Any status on this bug and if the driver has been released?

(hehe, try to help now I'm pushy? LOL)

Comment 15 Mike A. Harris 2003-02-13 11:05:38 UTC
I haven't heard back an email response from the Savage driver author,
and there is no Savage driver update released yet, so I'm assuming that
he is busy with non-XFree86 related things currently and that the
driver is unmaintained.

I am changing the Savage/MX variants to use the "vesa" driver for our
next release.  If 'vesa' doesn't work, then the hardware is considered
unsupported, and only hardware that works with the 'savage' driver is
supported.

Comment 16 Mike A. Harris 2003-02-13 11:34:13 UTC

*** This bug has been marked as a duplicate of 80346 ***

Comment 17 Red Hat Bugzilla 2006-02-21 18:50:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.