Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80249 - keyboard layout switcher hot key doesn't work reliably
Summary: keyboard layout switcher hot key doesn't work reliably
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-applets
Version: phoebe
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-23 09:48 UTC by Alexandre Oliva
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-23 14:57:30 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2002-12-23 09:48:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
If you choose Mod1-Shift_L (the default) as the keyboard layout switch hotkey,
it only switches the keyboard layout if you hold alt, press left shift, release
shift and then release alt.  If you release alt before shift, it seems to revert
to the original state.  Is this intentional, just to avoid accidental switching? 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Press Alt and hold
2.Press shift
3.Release Alt


Actual Results:  Keyboard layout is unchanged.

Expected Results:  I'd expect it to change.

Additional info:

I can see that this may well be a feature, but it can be annoying if you release
both keys almost at the same time.  It could try to time the events to avoid
unintended changes, e.g., if the time between the pressing of the second key and
the releasing either key is larger than the interval between the pressing of
both keys, then it's an intended layout switch.  This helps avoid pressing the
shift right before releasing the alt when a layout switch is not intended.

Comment 1 Havoc Pennington 2002-12-23 16:01:03 UTC
This should at least be copied upstream to bugzilla.gnome.org

Also, if you use the keyswitcher applet - could you try some of the 
others on the internet, such as http://gswitchit.sourceforge.net/
and see if we should use those instead?

Comment 2 Alexandre Oliva 2002-12-25 22:10:34 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=101960

Comment 3 Havoc Pennington 2003-01-14 20:47:31 UTC
This applet seems to lack upstream love.

I have no idea if this is a bug or intentional...

Comment 4 Alexandre Oliva 2003-01-23 14:57:30 UTC
Fixed in phoebe2.


Note You need to log in before you can comment on or make changes to this bug.