Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80237 - uic: relocation error: uic: undefined symbol: _ZTI7QGArray
Summary: uic: relocation error: uic: undefined symbol: _ZTI7QGArray
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: qt
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-23 01:32 UTC by Petri T. Koistinen
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-30 14:41:11 UTC


Attachments (Terms of Use)

Description Petri T. Koistinen 2002-12-23 01:32:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[petri@dsl-hkigw4e42 petri]$ uic
uic: relocation error: uic: undefined symbol: _ZTI7QGArray
[petri@dsl-hkigw4e42 petri]$ which uic
/usr/bin/uic
[petri@dsl-hkigw4e42 petri]$ rpm -qf /usr/bin/uic
qt-devel-3.0.5-17


Additional info:

Comment 1 Ngo Than 2002-12-30 13:43:15 UTC
Hmm, it looks like you have installed wrong glibc/libstdc++ rpm. Please install
the glibc and libstc++ rpm from 8.0.



Comment 2 Petri T. Koistinen 2002-12-30 13:46:55 UTC
What? How do make such accusations? I have not!

[petri@dsl-hkigw4e42 petri]$ rpm -q glibc
glibc-2.2.93-5
[petri@dsl-hkigw4e42 petri]$ rpm -q libstdc++
libstdc++-3.2-7
[petri@dsl-hkigw4e42 petri]$ 

Comment 3 Ngo Than 2002-12-30 14:41:11 UTC
It could be that you still have old version of qt on your system. You
should please check it again. 

Perhaps you should reinstall glibc/qt/libstdc++ from 8.0 with --force.

i cannot reproduce this problem on many machines with 8.0 here.
And i don't think it's a bug in 8.0.



Note You need to log in before you can comment on or make changes to this bug.