Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80231 - rhn-applet-gui is gone, and crashes if restarted
Summary: rhn-applet-gui is gone, and crashes if restarted
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhn-applet
Version: phoebe
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-22 22:55 UTC by Alexandre Oliva
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-11 11:06:52 UTC


Attachments (Terms of Use)
strace info (deleted)
2002-12-30 04:38 UTC, Nathan G. Grennan
no flags Details

Description Alexandre Oliva 2002-12-22 22:55:08 UTC
When I log in after an upgrade from 8.0 to the first public beta, the rhn applet
icon is gone from the notification area of the gnome panel.  If I try to restart
it, I get:

** ERROR **  file pygobject.c: line 122 (ygobject_lookup_class): assertion
failed: (type != NULL)
aborting
Trace/breakpoint trap

Could it be just because the machine used to be registered with the 8.0 install,
but is no longer registered in the new install (install from scratch, not upgrade).

Comment 1 Elton Woo 2002-12-28 20:48:52 UTC
In my case, I did a _clean_ install of Phoebe, rather than an update (over
8.0/Psyche).
The applet shows in the menus, but NEVER shows up in the panet (either under
Gnome, *or* KDE).

Comment 2 Nathan G. Grennan 2002-12-30 04:38:10 UTC
I tried recompiling it and instead of the error mentioned above it runs, and
appears in the panel. But if I select any of the options I get a Segmentation
fault. Since it is a python script I can't debug it with gdb. So I am going to
attach the last part of the output of strace.

Comment 3 Nathan G. Grennan 2002-12-30 04:38:37 UTC
Created attachment 88983 [details]
strace info

Comment 4 Aleksey Nogin 2003-01-07 01:39:24 UTC
Same assertion failure and abort here, after 8.0 -> Phoebe upgrade. (Note: I
already did "rm -rf /usr/lib/python2.2/site-packages/bonobo" as mentioned in bug
79652 and up2date does work for me).

Comment 5 Nathan G. Grennan 2003-01-07 10:13:13 UTC
I just created a new user and logged in. I found rhn-applet-gui working, but
then it still crashes on my main account. I think the out of the box issue is
lack of a recent version of rpm.

Comment 6 Daniel Veillard 2003-01-07 16:38:53 UTC
Okay, first I was able to reproduce the rhn applet start problem on Phoebe.
Second I upgraded with rhn-applet-2.0.7-1 which is in the Rawhide tree (or
will soon show up), that was sufficient to solve the initial problem, the
menus are functional, no crash and proper report of the status apparently.

The problem of the rhn-applet not showing up in the Gnome toolbar list
of applet is due to a change in the Gnome configuration path, I expect to
fix this in time for the release.

I don't know where the problem for Nathan G. Grennan main account comes from,
could you try to remove ~/.rhn-applet.cache and restart the applet ? Could
you also check that ~/.rhn-applet.conf has no trouble usually all entries
are empty except Consent=1 or some IgnoredPackages being defined.

Daniel

Comment 7 Aleksey Nogin 2003-01-11 00:41:10 UTC
After upgrading to rhn-applet-2.0.7-1 I no longer see any crashes.

Comment 8 Daniel Veillard 2003-01-11 11:06:52 UTC
Okay, note that to avoid a memory leak you aso need to update pygtk2
(see bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81341)

Daniel

Comment 9 Elton Woo 2003-01-11 20:18:48 UTC
I've updated stuff from Rawhide, including the glibc libraries and the rhn_applet.
It now works!


Note You need to log in before you can comment on or make changes to this bug.