Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80230 - xdpyinfo shows wrong monitor size on Dell Inspiron 8000 with 1600x1200 display
Summary: xdpyinfo shows wrong monitor size on Dell Inspiron 8000 with 1600x1200 display
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-22 22:09 UTC by Alexandre Oliva
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-24 18:55:49 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2002-12-22 22:09:29 UTC
xdpyinfo says the monitor dimensions are 542x406mm (75x75DPI) at 1600x1200,
whereas the actual dimensions are roughly 300x228mm.  Probing DPI from the
monitor reportedly doesn't work.  Is 75x75DPI the default, and the dimensions
computed from this?

Comment 1 Mike A. Harris 2002-12-27 02:31:22 UTC
The DPI is determined in the following order:

1) DDC probe
2) Commandline -dpi option / config file DisplaySize option
3) Default to 75x75dpi

If DDC probe is unsupported by the hardware, or if a KVM switch blocks it,
or if a driver doesn't support it, then it simply can't be autodetected at
all.  In this case, the DPI must be specified in the config file or on the
commandline.  If neither is present, the X server uses 75dpi by default.

I fail to see the bug here though.  Could you provide details of what exactly
you're reporting as buggy here?

Comment 2 Alexandre Oliva 2002-12-27 02:50:58 UTC
It was not as much of a bug report as a question on how X managed to come up
with the dimensions it did.

Since DDC probing doesn't actually work for these Dell Laptop LCD displays,
could we perhaps have anaconda/redhat-config-xfree86 to set DisplaySize?  For
`Dell 1600X Laptop Display Panel', the correct settings would be:
  DisplaySize 304 228


Comment 3 Alexandre Oliva 2003-01-23 14:22:36 UTC
DisplaySize setting not put in by installer in phoebe2.  Also, is there anything
that can be done about having this display auto detected?  Where should I look
to find out why it's not being detected by the installer nor redhat-config-xfree86?

Comment 5 Mike A. Harris 2003-05-12 23:41:49 UTC
Lots of LCD panels simply are not DDC probeable as it isn't implemented in
the hardware itself.  There's nothing we can do about a panel that doesn't
respond to DDC.

In order for these to work out of the box, we would require a laptop database
which stores the panel dimensions and whatnot for all laptops and panels that
are not DDC probeable, or some alternate way via reading the BIOS of the
systems.  Our config tools could then use this information.  However, we do
not have such a database, nor a way of reading the information from the BIOS
(which is likely to be completely different on every laptop model) currently,
so the only way to do this is for the user to hard code it into the config
file.

It isn't something that is really an XFree86 problem per se, at least IMHO.
It's something that is more in the hardware detection and config-tool
area.  One could argue that XFree86 could implement the BIOS munging hardware
detection, and supply a database, but that would be something that would have
to come from XFree86.org, and not something we'd be implementing ourselves,
at least not any time soon.

Caveat:  I'm not even completely sure if any of this is that reasonably doable
at all without hardware manufacturer cooperation, the above is all theoretical
and could be way off base.


Comment 6 Alexandre Oliva 2003-10-18 18:14:00 UTC
A long time ago, you said it might be possible to add the dimensions to the
hardware database, such that the installer would take care of adding them.  This
still hasn't been done.  For reference, the dimensions for a Dell 1600x1200
Laptop Display Panel are:
DisplaySize 304 228

Comment 7 Mike A. Harris 2004-09-24 18:55:49 UTC
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.


Comment 8 Alexandre Oliva 2004-10-05 01:10:44 UTC
It works in FC3-re1001.0, and probably in FC2 as well.  Thanks,


Note You need to log in before you can comment on or make changes to this bug.